summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2016-08-24 00:42:56 -0700
committerDaniel Campbell <zlg@gentoo.org>2016-08-24 00:43:57 -0700
commit62c242b56d5a4024e52982cb289a35b29195ce25 (patch)
tree05f5006a3821dcdb32bc5d11132b80106b9bb7ea
parentmedia-sound/ardour: new sources location and elog comment (diff)
downloadgentoo-62c242b56d5a4024e52982cb289a35b29195ce25.tar.gz
gentoo-62c242b56d5a4024e52982cb289a35b29195ce25.tar.bz2
gentoo-62c242b56d5a4024e52982cb289a35b29195ce25.zip
dev-tcltk/tcl3d: Correct path typo, fixes #563400
Gentoo-Bug: 563400 Gentoo-Bug-URL: https://bugs.gentoo.org/563400 Package-Manager: portage-2.3.0
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild b/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..a5ccdf3f0dcc
--- /dev/null
+++ b/dev-tcltk/tcl3d/tcl3d-0.4.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Tcl bindings to OpenGL and other 3D libraries"
+HOMEPAGE="http://www.tcl3d.org"
+SRC_URI="http://www.tcl3d.org/download/${P}.distrib/${PN}-src-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-games/ode
+ dev-lang/tk:0=
+ dev-lang/tcl:0=
+ media-libs/libsdl
+ media-libs/ftgl
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.19"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ TCL_VERSION=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
+ einfo "Configuring for Tcl ${TCL_VERSION[0]}.${TCL_VERSION[1]}"
+ sed -i \
+ -e 's:^\(TCLMAJOR\) *=\(.*\)$:\1 = '${TCL_VERSION[0]}':' \
+ -e 's:^\(TCLMINOR\) *=\(.*\)$:\1 = '${TCL_VERSION[1]}':' \
+ config_Linux* || die
+
+ # fix libSDL link
+ sed -i \
+ -e 's:-lSDL-1\.2:-lSDL:g' \
+ tcl3dSDL/Makefile || die
+}
+
+src_compile() {
+ append-flags -mieee-fp -ffloat-store -fPIC
+ use debug || append-flags -DNDEBUG
+
+ emake \
+ INSTDIR="/usr" OPT="${CFLAGS}" CC="$(tc-getCC) -c" \
+ CXX="$(tc-getCXX) -c" LD="$(tc-getLD)" \
+ WRAP_FTGL=1 WRAP_SDL=1 WRAP_GL2PS=0 WRAP_ODE=1
+}
+
+src_install() {
+ emake INSTDIR="${D}/usr" DESTDIR="${D}" INSTLIB="${D}/usr/$(get_libdir)" install
+}