summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-21 10:43:02 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-21 09:58:48 -0400
commit62c4b5abf2b2f59aa9187c9714f4a3d8c75f64c2 (patch)
tree04b166c3b0df80dde46d9c96fef6876d8537f17f
parentapp-admin/pwgen-2.08-r2: fix c2x errors (diff)
downloadgentoo-62c4b5abf2b2f59aa9187c9714f4a3d8c75f64c2.tar.gz
gentoo-62c4b5abf2b2f59aa9187c9714f4a3d8c75f64c2.tar.bz2
gentoo-62c4b5abf2b2f59aa9187c9714f4a3d8c75f64c2.zip
www-client/epiphany: Version bump to 44.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30677 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-44.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 45322f15b246..fdfdc6b445d0 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,4 @@
DIST epiphany-43.1.tar.xz 3893416 BLAKE2B 3706b89269a48c7132a8e8a1807345482d16ed87d860974e74c49f2d0bb2dd05b31f9e9c02d4675ccab2b721ffc2f62196a2ca3f3bd5cb52696cf5159465ee5b SHA512 1f54864c35f988b009b739e996dca1735f5222bf9fc5594eed3aa07d673db6f8f8870536b17985c318f39dfac79bce236118d863f9963944bc16cdaec469ca7a
DIST epiphany-44.0.tar.xz 3991296 BLAKE2B 44f1b4b5ac9a7b78c9fdb15e8f6345c13d7381b9bfe39565d59d9d74b51540510f36bd6ba6082a724c21828e95879d37648a3352929852f4f330a92838f9aef3 SHA512 a023429ea3e9e7db01bb5e93c33489891058cc49438ff4f365b0321175b1c484c3d20dcb96bde026f416dfdfeab6bfc3719908f1ac69eb9a162c88b3afaf01e6
DIST epiphany-44.1.tar.xz 3991788 BLAKE2B 7dfe437cee729c1799e7d9c5379f70473dd7db6ca854876edcf65e8be32ca9160861a90767f166a597a81f5abf7d5a96f63b1a147e263f15b4068784c69c99c0 SHA512 3f1736d3358d5898b04db7b57ebfe33d7becab4ebac4285ca96356e5c808bde7ee3db504da99afd34269a41741bc5b2e8d38ae5ffcbb513c585e85d9e2e46c19
+DIST epiphany-44.2.tar.xz 3991788 BLAKE2B c18e3c952a1e71e498646017886caba82325e220b2682c8d804e2b5e40b7a80bc3521c0e3c098d8a24732ddf727f6b37936ffae154599a0c8c4a5aa90765f1a5 SHA512 026536a1d0a74059e9f642ddf38156f80f0c244ace6449caa0908a49daf3bcea735745050abe6f565224c73489d0ce12da2f2ac907d062ac270f24b3b045f86e
diff --git a/www-client/epiphany/epiphany-44.2.ebuild b/www-client/epiphany/epiphany-44.2.ebuild
new file mode 100644
index 000000000000..53e8f0938976
--- /dev/null
+++ b/www-client/epiphany/epiphany-44.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web https://gitlab.gnome.org/GNOME/epiphany"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.9.0:4=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=dev-libs/glib-2.70.0:2
+ gnome-base/gsettings-desktop-schemas
+ >=media-libs/gstreamer-1.0
+ >=gui-libs/gtk-4.9.3:4
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=gui-libs/libadwaita-1.3_rc:1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.99.4:3.0
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/nettle-3.4:=
+ >=dev-libs/libportal-0.6:0=[gtk]
+ >=dev-db/sqlite-3.22:3
+ >=net-libs/webkit-gtk-2.40.0:6=
+
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dgranite=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk:6[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk:6 is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}