summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 12:46:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 14:18:20 +0100
commit62c71f11d62630175f6957124f0f197273b00602 (patch)
treeb5657caf6d1132137ab0aef7d58ffd266ff2fe15
parentdev-python/jsonschema-spec: Bump to 0.1.3 (diff)
downloadgentoo-62c71f11d62630175f6957124f0f197273b00602.tar.gz
gentoo-62c71f11d62630175f6957124f0f197273b00602.tar.bz2
gentoo-62c71f11d62630175f6957124f0f197273b00602.zip
dev-python/qiskit-terra: Bump to 0.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qiskit-terra/Manifest1
-rw-r--r--dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/dev-python/qiskit-terra/Manifest b/dev-python/qiskit-terra/Manifest
index 3874ca212c89..923c3c1173cd 100644
--- a/dev-python/qiskit-terra/Manifest
+++ b/dev-python/qiskit-terra/Manifest
@@ -55,6 +55,7 @@ DIST pyo3-macros-backend-0.17.3.crate 49992 BLAKE2B a922c3c2c1f494002fa8592704c4
DIST pyo3-macros-backend-0.18.0.crate 48261 BLAKE2B a95dee8233a7fed386860f052202348753823091cce26fa0a41c659da7a62cb0c20ff9a540c33366ce57a90aa953699c9b555dab817d43855f0911ca7cec2ff3 SHA512 051c5bdcdeb60d3a19ecd12099d5906eb7fa4624005e3207b1a225fc6b9cd6606e9b9f9f4f145f934ac88e1915e587ed760734e738a752df72cb20d9550a78d4
DIST qiskit-terra-0.22.3.gh.tar.gz 9258519 BLAKE2B 5046390a9ecec5508d558e2d4609b0308d37367cf82ffb677d0e540e8213f9fb82e8774c4c128072b6c89fef190764c41e6f9de3ab754ba1a5884d21002f930a SHA512 787e0a3ad95974f3fc8300937569704da4db7b2681f985ba359a30170516587f4be9523e7c9892dc0e2ccf0faf2bdf6e9905bb5988dc1022467ac313ec7f0bc4
DIST qiskit-terra-0.23.0.gh.tar.gz 9524936 BLAKE2B 409e9de2012bc10394669499a4b0f0c9eb5ca730b859ebd04bc620354b86a295610433e3a49e6300904b3927309d7fa52149de16a1083f89667928cb016448e5 SHA512 cc6fc9d7b794c00a4fad549c8be2d52021470c4d8d39a51de8c312c0096e6fc2af27e9234d0dfbcf96a8620e28ba9a075ccdd939d59e72f66078cd671f92b37f
+DIST qiskit-terra-0.23.1.gh.tar.gz 9525036 BLAKE2B f02afd580cac2dfd05bb50ed1744d3d084eb2e90175249bd0eea8fb741058b1bd4f5db16f8ababe643732934e863714fce1807c23aa044adab0406dbbebf40de SHA512 46fb5721782b92f013cce9833bf86e4cd725e80612894423a1c80837e8ad11439ef898df1f5228fd2a7c40cbbfc309d482b9b54a954210871abdcd4018d625d2
DIST quote-1.0.21.crate 28030 BLAKE2B 547344ba9272874f5fbb4bd27a69ef5be99823e10e1318afe71971b18f37e9c73d54168f16efb82c53a332e4874c80a82ea951fb2c85fad50cdfe783622b79fc SHA512 0728eb4df7e1f7c4d32ab08c901c2c969db8eb46b03bcec3e4956a4f6b360939d32abc6b6ebd7a31058e8e9b69c3d995a24cb484f93656f05b4ee963be1c74fc
DIST rand-0.8.5.crate 87113 BLAKE2B 516f26bb2a969d0d79e957818133f35d2c0b4d9f1b401098ea23c5b80d27599e842b9298c0c5e46e2a6cb6953857bf8a9fb71ec9366c5ce6708cf17df14f179c SHA512 8b33a8988906ba5e2057a9a84bdd11f867a5536c22f5056eec59ed4ec4e3a6da2fd773da4c0510d343762e5a4ea0f007db4c4a7cef87a47f90e36c1a84d86fb2
DIST rand_chacha-0.3.1.crate 15251 BLAKE2B 645771b2c3e274f085e0837a20306b1d59f6e9032fba8eb38a6d1b30180d15e2f89ffa2a162bf6358da41e030098242d81e71dab4321980d0a4f6ddfc2974ce3 SHA512 8198c580b1b9b0429758ffa49cd8138fa3ce724f0dcf73c767ea7e55611d6a2e4c7cad9950896510def500ce4062b594386c947ac3d89425b4e5c9b04d0b8075
diff --git a/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild b/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild
new file mode 100644
index 000000000000..3fcd499d482c
--- /dev/null
+++ b/dev-python/qiskit-terra/qiskit-terra-0.23.1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ ahash-0.7.6
+ ahash-0.8.0
+ autocfg-1.1.0
+ bitflags-1.3.2
+ cfg-if-1.0.0
+ crossbeam-channel-0.5.6
+ crossbeam-deque-0.8.2
+ crossbeam-epoch-0.9.11
+ crossbeam-utils-0.8.12
+ either-1.8.0
+ fixedbitset-0.4.2
+ getrandom-0.2.8
+ hashbrown-0.11.2
+ hashbrown-0.12.3
+ hermit-abi-0.1.19
+ indexmap-1.7.0
+ indoc-1.0.7
+ libc-0.2.137
+ libm-0.2.5
+ lock_api-0.4.9
+ matrixmultiply-0.3.2
+ memoffset-0.6.5
+ memoffset-0.8.0
+ ndarray-0.15.6
+ num-bigint-0.4.3
+ num-complex-0.4.2
+ num-integer-0.1.45
+ num-traits-0.2.15
+ num_cpus-1.13.1
+ numpy-0.18.0
+ once_cell-1.16.0
+ parking_lot-0.12.1
+ parking_lot_core-0.9.4
+ petgraph-0.6.2
+ ppv-lite86-0.2.16
+ priority-queue-1.2.0
+ proc-macro2-1.0.47
+ pyo3-0.18.0
+ pyo3-build-config-0.18.0
+ pyo3-ffi-0.18.0
+ pyo3-macros-0.18.0
+ pyo3-macros-backend-0.18.0
+ quote-1.0.21
+ rand-0.8.5
+ rand_chacha-0.3.1
+ rand_core-0.6.4
+ rand_distr-0.4.3
+ rand_pcg-0.3.1
+ rawpointer-0.2.1
+ rayon-1.6.0
+ rayon-core-1.10.1
+ redox_syscall-0.2.16
+ rustc-hash-1.1.0
+ rustworkx-core-0.12.1
+ scopeguard-1.1.0
+ smallvec-1.10.0
+ syn-1.0.103
+ target-lexicon-0.12.4
+ unicode-ident-1.0.5
+ unindent-0.1.10
+ version_check-0.9.4
+ wasi-0.11.0+wasi-snapshot-preview1
+ windows-sys-0.42.0
+ windows_aarch64_gnullvm-0.42.0
+ windows_aarch64_msvc-0.42.0
+ windows_i686_gnu-0.42.0
+ windows_i686_msvc-0.42.0
+ windows_x86_64_gnu-0.42.0
+ windows_x86_64_gnullvm-0.42.0
+ windows_x86_64_msvc-0.42.0
+"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit cargo distutils-r1 multiprocessing
+
+DESCRIPTION="Terra is the foundation on which Qiskit is built"
+HOMEPAGE="
+ https://github.com/Qiskit/qiskit-terra/
+ https://pypi.org/project/qiskit-terra/
+"
+SRC_URI="
+ https://github.com/Qiskit/qiskit-terra/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ $(cargo_crate_uris)
+"
+
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 MIT
+ Unicode-DFS-2016
+ || ( LGPL-3 MPL-2.0 )
+"
+SLOT="0"
+IUSE="+visualization"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-python/rustworkx-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.10[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.3[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-constraint-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/symengine-0.8[${PYTHON_USEDEP}]
+ >=dev-python/tweedledum-1.1[${PYTHON_USEDEP}]
+ visualization? (
+ >=dev-python/matplotlib-3.3[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.3.0[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pylatexenc-1.4[${PYTHON_USEDEP}]
+ >=dev-python/seaborn-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/cython-0.27.1[${PYTHON_USEDEP}]
+ test? (
+ app-text/poppler[png]
+ >=dev-python/ddt-1.4.4[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.24.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/qiskit-aer[${PYTHON_USEDEP}]
+ >=sci-libs/scikit-learn-0.20.0[${PYTHON_USEDEP}]
+ )
+"
+
+# Files built without CFLAGS/LDFLAGS, acceptable for rust
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/qiskit/_accelerate.*.so"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/python/transpiler/test_unitary_synthesis_plugin.py::TestUnitarySynthesisPlugin
+ test/python/transpiler/test_unitary_synthesis.py::TestUnitarySynthesis::test_two_qubit_synthesis_not_pulse_optimal
+ )
+ local EPYTEST_IGNORE=(
+ # TODO, also apparently slow
+ test/randomized/test_transpiler_equivalence.py
+ )
+
+ rm -rf qiskit || die
+ epytest -p xdist -n "$(makeopts_jobs)"
+}