summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-27 11:55:18 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-27 12:41:09 +0100
commit62d6a030cd0306a01250457491173d654684354e (patch)
tree5bff366fdf74680a92ab8ea56a243468bb211a14
parentdev-python/hypothesis: Remove redudant versions (diff)
downloadgentoo-62d6a030.tar.gz
gentoo-62d6a030.tar.bz2
gentoo-62d6a030.zip
dev-python/hypothesis: Bump to 4.47.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.47.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index dddbef8daa8a..66bbe19de1b7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc
DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad2582eb23bd8ab2e218f1bde82ba1639123f32e8c147313c22b15781d8986574813b5f6eb7c23ce28367e86bb304d33a23f179fa0 SHA512 7d9788b351196fc20e66e210b7d60b4ddb1507b85cf5a29de228600e07f676ccd1352f5d2ab0820b3c8c1a1e8ff145225f00a25aec5f325cc7405ffd0dfcd9f7
DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
DIST hypothesis-python-4.47.1.tar.gz 3253826 BLAKE2B 6daae1eef6c36b874f44d1e3c7a4ebd18e76c6a4d1543062cc53bbb93d65e1e0a441b084c97cb13f79867e4e77830c2ce71ef779f7086fdfb99756226911d81b SHA512 e3de34822b018a3d7ef474a90eff6b74ce3f214e374cadec34af80b8bdea90bcbc4f8e3de6cac9218729d99e8ffa12dd8216a53078801ba45b76552fac2a6c35
+DIST hypothesis-python-4.47.3.tar.gz 3254272 BLAKE2B 6f9b134b77cfc1e72012992c7b352d3cd52c503f1607f88638b54c9258fd80ff02c153231cda9cb81314580e79abcc749b285787d147fa0a7344ee077b5bad9f SHA512 1bb2737f505169d361350d63b09e66874b8d82f0363911cf6b7a73819629d71f62ebfba6d1f1129b6fc76588feb8bf171b6106d6209527d60694cc6268212137
diff --git a/dev-python/hypothesis/hypothesis-4.47.3.ebuild b/dev-python/hypothesis/hypothesis-4.47.3.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.47.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}