summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:49:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:18:04 +0200
commit62ec2f4c1d498bcc720788c72a9ec93f5f32bb76 (patch)
treea9659cc376588f599fd7ba5a155481a4d196432c
parentdev-python/tempora: Bump to 5.3.0 (diff)
downloadgentoo-62ec2f4c1d498bcc720788c72a9ec93f5f32bb76.tar.gz
gentoo-62ec2f4c1d498bcc720788c72a9ec93f5f32bb76.tar.bz2
gentoo-62ec2f4c1d498bcc720788c72a9ec93f5f32bb76.zip
dev-python/Levenshtein: Bump to 0.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.21.1.ebuild46
-rw-r--r--dev-python/Levenshtein/Manifest1
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.21.1.ebuild b/dev-python/Levenshtein/Levenshtein-0.21.1.ebuild
new file mode 100644
index 000000000000..b9f8496fcc68
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.21.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/maxbachmann/Levenshtein/
+"
+SRC_URI="
+ https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-cpp/rapidfuzz-cpp-2.0.0
+"
+RDEPEND="
+ <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/Levenshtein/Manifest b/dev-python/Levenshtein/Manifest
index 0f02beaf7ce7..9289e0dd7718 100644
--- a/dev-python/Levenshtein/Manifest
+++ b/dev-python/Levenshtein/Manifest
@@ -1 +1,2 @@
DIST Levenshtein-0.21.0.gh.tar.gz 36616 BLAKE2B 8408ba8231a8ff3f6bf9e6cc7ea763061ca1c826236d74877213caef0ce736695865dc3c02565cce960b794d07f96f6413ca144565d6693debf90a1b5718524b SHA512 bb1cf70497e89db5b427eb4ac79708d205fc9edfc9588d30c63ef6e3e77b9369c8892edc31c32cb135d54947e8eedb770d06a7d5c6f8743d44378d7d1a12d459
+DIST Levenshtein-0.21.1.gh.tar.gz 36656 BLAKE2B b2e5325cd836b646d876fb59d1062c7bb415d707076d9692fff2b98e00dce29d813fb68c139283d66f8800fd836ec93b709ac7ebfaa6d9cca563b65c428019ef SHA512 5fd823e7871c53f521198275b7ebb3189f7208347d41f306686e11446397c4ed5b2672230cbfa76a0c2f1afcc08fd24c6c7468d808be2a09bb9c31c2d9f61f16