summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-27 10:29:49 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-28 16:19:29 +0200
commit6302726dcb462651759121a0399ca3bf21704646 (patch)
treee94216a76763a727b0aef2bceb7358a644212c4c
parentapp-arch/tardelta: bump to python 3.9, 3.10 (diff)
downloadgentoo-6302726d.tar.gz
gentoo-6302726d.tar.bz2
gentoo-6302726d.zip
dev-python/pylru: bump python 3.{9,10}, add tests
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylru/pylru-1.2.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/pylru/pylru-1.2.0.ebuild b/dev-python/pylru/pylru-1.2.0.ebuild
index 73f3e86bb7fa..f22b1b0e9eb6 100644
--- a/dev-python/pylru/pylru-1.2.0.ebuild
+++ b/dev-python/pylru/pylru-1.2.0.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A least recently used (LRU) cache for Python"
HOMEPAGE="https://github.com/jlhutch/pylru"
-LICENSE="GPL-2"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
-BDEPEND=""
-RDEPEND=""
+python_test() {
+ "${EPYTHON}" test.py || die "tests failed under ${EPYTHON}"
+}