summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-30 00:03:49 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-30 00:06:52 -0400
commit6305fc85cdd3d0998758528dbd864a29c0b00f00 (patch)
tree258fc2f47a842e43c8fda776d00a05a89f31bc54
parentdev-ruby/rex-text: drop random bins (diff)
downloadgentoo-6305fc85cdd3d0998758528dbd864a29c0b00f00.tar.gz
gentoo-6305fc85cdd3d0998758528dbd864a29c0b00f00.tar.bz2
gentoo-6305fc85cdd3d0998758528dbd864a29c0b00f00.zip
dev-ruby/metasploit_payloads-mettle: initial ebuild, metasploit dep, absolutely doesn't make msfconsole happy
Package-Manager: portage-2.3.0
-rw-r--r--dev-ruby/metasploit_payloads-mettle/Manifest1
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metadata.xml14
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild48
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/metasploit_payloads-mettle/Manifest b/dev-ruby/metasploit_payloads-mettle/Manifest
new file mode 100644
index 000000000000..1cb185b5b13b
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/Manifest
@@ -0,0 +1 @@
+DIST metasploit_payloads-mettle-0.0.6.gem 3259904 SHA256 b9b0a5062dc27345e23fc62f26047533d153b322b1d19b5dbae60c7deb08fc23 SHA512 c95c4774f1295e6e5953fdf2738560a2f5c3380d9a0de72dd435d475e05948cb36ca6596406c0ad7e12f7e1e7db831d6651c579458b99a252a678197874f7c34 WHIRLPOOL 7261a3efa2f5d42011a1a1c697e70d31e462c4d65316bb81b88990407ed36b36af2f8298bbbd38157bfc7301d58e5b69ea3abaee9735cab3a392cb0f7617ef92
diff --git a/dev-ruby/metasploit_payloads-mettle/metadata.xml b/dev-ruby/metasploit_payloads-mettle/metadata.xml
new file mode 100644
index 000000000000..4bb41cf944a8
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/mettle</remote-id>
+ <remote-id type="rubygems">metasploit_payloads-mettle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild
new file mode 100644
index 000000000000..d99fb517ae90
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="build"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's next-gen Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit_payloads-mettle"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips-linux-muslsf/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips64-linux-muslsf/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/aarch64-linux-musl/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5b-linux-musleabi/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5l-linux-musleabi/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/i486-linux-musl/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/mipsel-linux-muslsf/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc-linux-muslsf/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc64le-linux-musl/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/x86_64-linux-musl/bin/mettle
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${P}/build"
+ EOF
+}