summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-25 18:57:13 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:25:54 +0000
commit631108260ba6ca51f19778e88d990b15e4375db6 (patch)
tree54c1d4e8efaaee870a3583ae6338a1add9898130
parentapp-misc/goobook: Mark ALLARCHES (diff)
downloadgentoo-631108260ba6ca51f19778e88d990b15e4375db6.tar.gz
gentoo-631108260ba6ca51f19778e88d990b15e4375db6.tar.bz2
gentoo-631108260ba6ca51f19778e88d990b15e4375db6.zip
dev-python/ansi: Bump to 0.2.0
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/ansi/Manifest1
-rw-r--r--dev-python/ansi/ansi-0.2.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ansi/Manifest b/dev-python/ansi/Manifest
index 04b85493348e..2873ac3c369a 100644
--- a/dev-python/ansi/Manifest
+++ b/dev-python/ansi/Manifest
@@ -1 +1,2 @@
DIST ansi-0.1.5.tar.gz 4606 BLAKE2B 5f88319f05262511e99c8385946b61e2ed7219217ae8e811e8c1762fbd402f2fcaf69bcd6e4caf35d1f982afebcce5a98c721e2598032891382010ff7b928c55 SHA512 03365aca71b4966ca0c78b1563400afe414c86288b4e8ede969fb9c79cd4da4722de8cedae4e86c2f536f82eda42845482e041a396cb33852d3e4ff639dbbb64
+DIST ansi-0.2.0.tar.gz 5173 BLAKE2B 436caa8e1f36e96f1844e79e3a0ff0c4099e76b25ce9f56c9d8663aeeb650f32fba75a14fe8548f557fb020e2340707272fdda4cdd3c245c903a4f801ae48413 SHA512 22c69b5030f03eca9470e288c16e62042ccd02ef2e232600a4fab629354601d5da0f7c16b60dae7293c69255e5d4125298890d99dba8e5387960a5be60b92d61
diff --git a/dev-python/ansi/ansi-0.2.0.ebuild b/dev-python/ansi/ansi-0.2.0.ebuild
new file mode 100644
index 000000000000..afc8d0584e2f
--- /dev/null
+++ b/dev-python/ansi/ansi-0.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest