summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-06 05:08:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-06 05:31:33 +0100
commit633b11507f4731ca1b16d77afaf7354d494fb90a (patch)
treef5efd23368a34a77202d4fbc557a035f8c3b57a5
parentdev-python/hypothesis: Bump to 6.67.1 (diff)
downloadgentoo-633b1150.tar.gz
gentoo-633b1150.tar.bz2
gentoo-633b1150.zip
dev-python/pypdf: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-3.4.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 04712ecd076e..3d5ea696c42c 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,2 +1,3 @@
DIST pypdf-3.3.0.gh.tar.gz 6803536 BLAKE2B ff70995882581c816fbf7410232c68e9649632161b4927543924a11b1a0a816f1178be399079e32078fe8d89a2aa9cd0eb1562409dc8e7bd388cad3afde37198 SHA512 5db25d6c4b41a1d19b45fa907f53e0106e01c93eb4152079dc4ffbd7bf28fbf8915bf0e3bf1af4a371e805657884fe2c42de4856944085ca7bc07a477f3ba588
+DIST pypdf-3.4.0.gh.tar.gz 6931831 BLAKE2B 037ac998cc1e3d078281b64183197678a80345731f6d4691b00f9e546eb61eaa34c4d7f4b704191c887975517da73359983f1b7405776e99257f79b1604dafc0 SHA512 9bee70a039c42533b600f1e95e28a4889d7df212bae18deca7d88501008d3a3e2b4d7fe36134e947cb14b0acc650126688c358ce2b662917a4c6df46241db1ab
DIST pypdf-sample-files-0fe84b30ed33ff3daa9293e44349b8618f135699.gh.tar.gz 9027166 BLAKE2B 912bb9fbd632bd0ad2cc2e865a1e6870ad7064aa2cf4d6f96217f63ac685e9a511f0bb20c22d48ae970a2eb171b27a0fa680fa42892425531f69735840cf741b SHA512 07a71a3566dabcea5dc8a549949d0f0c0f9483d5d9f85851d6e4e702dd374b348469a80e5300d18983e560ee9a44d0639b55eb338023b9ebbdb26c6f8c455e07
diff --git a/dev-python/pypdf/pypdf-3.4.0.ebuild b/dev-python/pypdf/pypdf-3.4.0.ebuild
new file mode 100644
index 000000000000..646a669f191b
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=0fe84b30ed33ff3daa9293e44349b8618f135699
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+S=${WORKDIR}/pypdf-${PV}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+RESTRICT="test"
+# 150+ tests require network, too many to deselect
+PROPERTIES="test_network"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # dead URL
+ # https://github.com/py-pdf/pypdf/issues/1526
+ tests/test_xmp.py::test_issue585
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}