summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-10 09:50:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-10 09:51:18 +0100
commit635aa9c605e2499959fecd625bba22e72e367918 (patch)
tree1abb8681d99a01a5cf40d13dd50344c568e8177b
parentdev-ros/pluginlib: revbump (diff)
downloadgentoo-635aa9c605e2499959fecd625bba22e72e367918.tar.gz
gentoo-635aa9c605e2499959fecd625bba22e72e367918.tar.bz2
gentoo-635aa9c605e2499959fecd625bba22e72e367918.zip
dev-ros/pluginlib: Remove old
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--dev-ros/pluginlib/Manifest2
-rw-r--r--dev-ros/pluginlib/files/gentoo.patch34
-rw-r--r--dev-ros/pluginlib/pluginlib-1.10.5.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-1.11.0.ebuild27
4 files changed, 0 insertions, 90 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index a1d1aa7745ef..ccb761bb5d62 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1,3 +1 @@
-DIST pluginlib-1.10.5.tar.gz 21470 SHA256 53a0ccb7a4654d464271189fc44ba23d6be8d3ecdfb40506b9d9fb4a87f19d6c SHA512 619c552c7f6d59f02f580204477e789e2adf15ea53dfdf1d3fe3fc6e65e34dbfe1d7e7ae60b833bbf589c2afd49dc09187222e989de902758475509b8cf7cd88 WHIRLPOOL c441fbee18fa152d900e0b49198cc2b0f75a85f801bc756bc1d56f4153360e2ddfc3c63223a57fbc7ee299aef4313bd55c147fe614d6fcca708f7302ac9c52fd
-DIST pluginlib-1.11.0.tar.gz 21555 SHA256 f5acf838cdf15538505b670dfdf93a0c5e453d222464d729d71a22513a60e2ca SHA512 2ef27759a6fb3db0354ffd28f2de5781405d4515dad028cbba6e108aa2eb79da56bbcb8ad4dab5686a9dc59d031bfd06ca713382e99258ecdf78fc45a877e588 WHIRLPOOL 71fa457e3bd0c93f2ea68729086b6f9b1b2653f126bdec3f461ad26cb37237c27397cca8d1c5dcf74e96b72988c025738d20ef303ac6d12ae7fc17d4b3bb8a02
DIST pluginlib-1.11.1.tar.gz 21621 SHA256 bee838a9e62c8e889e8354f6ec5c76493f3aa6df5d19c30110068c82feb927c0 SHA512 1bafbc35334a482b2fc08afb7c1ed53ddbc579b121b728b96893c8b82a7070d9ecd8e6e6cffa54b3539def84db9dac79fe59feb93b2de6b8f113e0bfc10a8c00 WHIRLPOOL 1d05ddb55c800e0272e6c203804fdd0cdc966a6213df55a999e2ab5f14ff157ec84654d6155a1de77cdd15821776ad51918e0fa1072efbc1c08e539dd10ebce3
diff --git a/dev-ros/pluginlib/files/gentoo.patch b/dev-ros/pluginlib/files/gentoo.patch
deleted file mode 100644
index 6737f7666df1..000000000000
--- a/dev-ros/pluginlib/files/gentoo.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Find package.xml in ros_packages/package_name too as we moved it here.
-
-Index: pluginlib-1.10.4/include/pluginlib/class_loader_imp.h
-===================================================================
---- pluginlib-1.10.4.orig/include/pluginlib/class_loader_imp.h
-+++ pluginlib-1.10.4/include/pluginlib/class_loader_imp.h
-@@ -444,6 +444,7 @@ namespace pluginlib
- std::string package_name;
- boost::filesystem::path p(plugin_xml_file_path);
- boost::filesystem::path parent = p.parent_path();
-+ boost::filesystem::path basename = p.filename();
-
- //Figure out exactly which package the passed XML file is exported by.
- while (true)
-@@ -453,6 +454,11 @@ namespace pluginlib
- std::string package_file_path = (boost::filesystem::path(parent / "package.xml")).string();
- return(extractPackageNameFromPackageXML(package_file_path));
- }
-+ else if(boost::filesystem::exists(parent / "ros_packages" / basename / "package.xml"))
-+ {
-+ std::string package_file_path = (boost::filesystem::path(parent / "ros_packages" / basename / "package.xml")).string();
-+ return(extractPackageNameFromPackageXML(package_file_path));
-+ }
- else if (boost::filesystem::exists(parent / "manifest.xml"))
- {
- #if BOOST_FILESYSTEM_VERSION >= 3
-@@ -470,6 +476,7 @@ namespace pluginlib
- }
-
- //Recursive case - hop one folder up
-+ basename = parent.filename();
- parent = parent.parent_path().string();
-
- //Base case - reached root and cannot find what we're looking for
diff --git a/dev-ros/pluginlib/pluginlib-1.10.5.ebuild b/dev-ros/pluginlib/pluginlib-1.10.5.ebuild
deleted file mode 100644
index 75c645625a19..000000000000
--- a/dev-ros/pluginlib/pluginlib-1.10.5.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/pluginlib"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit ros-catkin
-
-DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=dev-ros/class_loader-0.3.5
- dev-ros/rosconsole
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-libs/boost:=
- dev-libs/tinyxml
- dev-ros/cmake_modules
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/gentoo.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-1.11.0.ebuild b/dev-ros/pluginlib/pluginlib-1.11.0.ebuild
deleted file mode 100644
index 4194e2cd13c4..000000000000
--- a/dev-ros/pluginlib/pluginlib-1.11.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/pluginlib"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit ros-catkin
-
-DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=dev-ros/class_loader-0.3.5
- dev-ros/rosconsole
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-libs/boost:=
- dev-libs/tinyxml2:=
- dev-ros/cmake_modules
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/gentoo.patch" )