summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-11-25 12:14:05 -0500
committerMatt Turner <mattst88@gentoo.org>2023-11-25 12:31:02 -0500
commit637e44f058d0f6d13a6339fe09ecaa5fddef4ba2 (patch)
tree4baf13d582e7be3f687c01cc1dd7ce617f6a39c0
parentx11-apps/xman: Drop old versions (diff)
downloadgentoo-637e44f0.tar.gz
gentoo-637e44f0.tar.bz2
gentoo-637e44f0.zip
x11-base/xorg-server: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xorg-server/Manifest1
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.8-deadlock.patch97
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.8-wfb.patch43
-rw-r--r--x11-base/xorg-server/xorg-server-21.1.8-r2.ebuild195
4 files changed, 0 insertions, 336 deletions
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 26f511e9d9ed..16f4b3d8b53f 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -1,2 +1 @@
-DIST xorg-server-21.1.8.tar.xz 4980208 BLAKE2B a223efe6d14b55bd133b7f8db75b7720ea0ae58f1eced0f6b20caf6e7045e7649a0923a1c6db5d649265375e6768fa9811477d2fa0da52d7a1e65cf4511535d2 SHA512 6104b3620ed2e1e27d9a8e963388bbe8785a764585b1bc03dbf5d719a92894773dda580d377ca18ceeab353e65a5d23cc947bab84a4012f9dd1eca31cac36937
DIST xorg-server-21.1.9.tar.xz 4935860 BLAKE2B 8e0a2e0f5fc4d06a08c1424fe618da9822e951f5b744b4cac1b1e14305ab598b162e4f08fb53ba5e60d0001257216755a576b470c961c26a909d66e9a46d1c77 SHA512 9044e1b9222616fb63aea444b75f4ca6582edb7d899018f8ea30359e57edf04b1555e69397ebc4d288f7e36d6b82a54dde3895f11d414573d229e908ac17bfe8
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.8-deadlock.patch b/x11-base/xorg-server/files/xorg-server-21.1.8-deadlock.patch
deleted file mode 100644
index 8da824119edf..000000000000
--- a/x11-base/xorg-server/files/xorg-server-21.1.8-deadlock.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-https://bugs.gentoo.org/909643
-https://gitlab.freedesktop.org/mesa/mesa/-/issues/116
-https://gitlab.freedesktop.org/mesa/mesa/-/issues/6685
-https://gitlab.freedesktop.org/xorg/xserver/-/commit/b98fc07d3442a289c6bef82df50dd0a2d01de71a
-
-From b98fc07d3442a289c6bef82df50dd0a2d01de71a Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Thu, 2 Feb 2023 12:26:27 -0500
-Subject: [PATCH] present: Send a PresentConfigureNotify event for destroyed
- windows
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This enables fixing a deadlock case on the client side, where the client
-ends up blocked waiting for a Present event that will never come because
-the window was destroyed. The new PresentWindowDestroyed flag allows the
-client to avoid blocking indefinitely.
-
-Signed-off-by: Adam Jackson <ajax@redhat.com>
-See-also: https://gitlab.freedesktop.org/mesa/mesa/-/issues/116
-See-also: https://gitlab.freedesktop.org/mesa/mesa/-/issues/6685
-Reviewed-by: Michel Dänzer <mdaenzer@redhat.com>
-(cherry picked from commit 462b06033e66a32308d940eb5fc47f5e4c914dc0)
---- a/present/present_event.c
-+++ b/present/present_event.c
-@@ -102,7 +102,8 @@ present_event_swap(xGenericEvent *from, xGenericEvent *to)
- }
-
- void
--present_send_config_notify(WindowPtr window, int x, int y, int w, int h, int bw, WindowPtr sibling)
-+present_send_config_notify(WindowPtr window, int x, int y, int w, int h,
-+ int bw, WindowPtr sibling, CARD32 flags)
- {
- present_window_priv_ptr window_priv = present_window_priv(window);
-
-@@ -122,7 +123,7 @@ present_send_config_notify(WindowPtr window, int x, int y, int w, int h, int bw,
- .off_y = 0,
- .pixmap_width = w,
- .pixmap_height = h,
-- .pixmap_flags = 0
-+ .pixmap_flags = flags
- };
- present_event_ptr event;
-
---- a/present/present_priv.h
-+++ b/present/present_priv.h
-@@ -43,6 +43,11 @@
- #define DebugPresent(x)
- #endif
-
-+/* XXX this belongs in presentproto */
-+#ifndef PresentWindowDestroyed
-+#define PresentWindowDestroyed (1 << 0)
-+#endif
-+
- extern int present_request;
-
- extern DevPrivateKeyRec present_screen_private_key;
-@@ -307,7 +312,7 @@ void
- present_free_events(WindowPtr window);
-
- void
--present_send_config_notify(WindowPtr window, int x, int y, int w, int h, int bw, WindowPtr sibling);
-+present_send_config_notify(WindowPtr window, int x, int y, int w, int h, int bw, WindowPtr sibling, CARD32 flags);
-
- void
- present_send_complete_notify(WindowPtr window, CARD8 kind, CARD8 mode, CARD32 serial, uint64_t ust, uint64_t msc);
---- a/present/present_screen.c
-+++ b/present/present_screen.c
-@@ -93,6 +93,15 @@ present_destroy_window(WindowPtr window)
- present_screen_priv_ptr screen_priv = present_screen_priv(screen);
- present_window_priv_ptr window_priv = present_window_priv(window);
-
-+ present_send_config_notify(window,
-+ window->drawable.x,
-+ window->drawable.y,
-+ window->drawable.width,
-+ window->drawable.height,
-+ window->borderWidth,
-+ window->nextSib,
-+ PresentWindowDestroyed);
-+
- if (window_priv) {
- present_clear_window_notifies(window);
- present_free_events(window);
-@@ -123,7 +132,7 @@ present_config_notify(WindowPtr window,
- ScreenPtr screen = window->drawable.pScreen;
- present_screen_priv_ptr screen_priv = present_screen_priv(screen);
-
-- present_send_config_notify(window, x, y, w, h, bw, sibling);
-+ present_send_config_notify(window, x, y, w, h, bw, sibling, 0);
-
- unwrap(screen_priv, screen, ConfigNotify);
- if (screen->ConfigNotify)
---
-GitLab
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.8-wfb.patch b/x11-base/xorg-server/files/xorg-server-21.1.8-wfb.patch
deleted file mode 100644
index 48cdbd017088..000000000000
--- a/x11-base/xorg-server/files/xorg-server-21.1.8-wfb.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-https://bugs.gentoo.org/885763
-https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/1114
-https://gitlab.freedesktop.org/xorg/xserver/-/commit/34a430a16ec2cb9851b1f2bc7fc2117e19b9fcc7
-
-From 34a430a16ec2cb9851b1f2bc7fc2117e19b9fcc7 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Thu, 13 Apr 2023 15:45:58 +0200
-Subject: [PATCH] fb: Declare wfbFinishScreenInit, wfbScreenInit for
- !FB_ACCESS_WRAPPER
-
-xf86-video-nouveau calls wfbScreenInit without defining
-FB_ACCESS_WRAPPER (which has other unintended side effects).
-Presently, this compiles and links because compilers still support
-implicit function declarations, but this is going to change fairly
-soon. This seems to be the most straightforward change to keep
-the driver building.
----
- fb/fb.h | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/fb/fb.h b/fb/fb.h
-index 08143a0d49..309f15294c 100644
---- a/fb/fb.h
-+++ b/fb/fb.h
-@@ -1027,7 +1027,6 @@ extern _X_EXPORT Bool
- int dpiy, int width, /* pixel width of frame buffer */
- int bpp); /* bits per pixel of frame buffer */
-
--#ifdef FB_ACCESS_WRAPPER
- extern _X_EXPORT Bool
- wfbFinishScreenInit(ScreenPtr pScreen,
- void *pbits,
-@@ -1049,7 +1048,6 @@ wfbScreenInit(ScreenPtr pScreen,
- int width,
- int bpp,
- SetupWrapProcPtr setupWrap, FinishWrapProcPtr finishWrap);
--#endif
-
- extern _X_EXPORT Bool
- fbFinishScreenInit(ScreenPtr pScreen,
---
-GitLab
-
diff --git a/x11-base/xorg-server/xorg-server-21.1.8-r2.ebuild b/x11-base/xorg-server/xorg-server-21.1.8-r2.ebuild
deleted file mode 100644
index b2831b509eba..000000000000
--- a/x11-base/xorg-server/xorg-server-21.1.8-r2.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-XORG_TARBALL_SUFFIX="xz"
-XORG_EAUTORECONF="no"
-inherit flag-o-matic xorg-3 meson
-EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
-
-DESCRIPTION="X.Org X servers"
-SLOT="0/${PV}"
-if [[ ${PV} != 9999* ]]; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-IUSE_SERVERS="xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- media-libs/libglvnd[X]
- dev-libs/libbsd
- dev-libs/openssl:0=
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libdrm-2.4.89
- >=x11-libs/libpciaccess-0.12.901
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont2-2.0.1
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/libxshmfence-1.1
- >=x11-libs/pixman-0.27.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-2.4.1-r3
- xorg? (
- >=x11-libs/libxcvt-0.1.0
- )
- xnest? (
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libX11-1.1.5
- )
- xephyr? (
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- !minimal? (
- >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
- >=media-libs/libepoxy-1.5.4[X,egl(+)]
- )
- udev? ( virtual/libudev:= )
- unwind? ( sys-libs/libunwind:= )
- selinux? (
- sys-process/audit
- sys-libs/libselinux:=
- )
- systemd? (
- sys-apps/dbus
- sys-apps/systemd
- )
- elogind? (
- sys-apps/dbus
- sys-auth/elogind[pam]
- sys-auth/pambase[elogind]
- )
- !!x11-drivers/nvidia-drivers[-libglvnd(+)]
-"
-DEPEND="${CDEPEND}
- >=x11-base/xorg-proto-2021.4.99.2
- >=x11-libs/xtrans-1.3.5
- media-fonts/font-util
- test? ( >=x11-libs/libxcvt-0.1.0 )
-"
-RDEPEND="${CDEPEND}
- !systemd? ( gui-libs/display-manager-init )
- selinux? ( sec-policy/selinux-xserver )
- xorg? ( >=x11-apps/xinit-1.3.3-r1 )
-"
-BDEPEND="
- sys-devel/flex
-"
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )
- elogind? ( udev )
- ?? ( elogind systemd )"
-
-UPSTREAMED_PATCHES=(
- "${FILESDIR}"/${P}-deadlock.patch
- "${FILESDIR}"/${P}-wfb.patch
-)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
- # needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
-)
-
-src_configure() {
- # bug #835653
- use x86 && replace-flags -Os -O2
-
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- local emesonargs=(
- --localstatedir "${EPREFIX}/var"
- --sysconfdir "${EPREFIX}/etc/X11"
- --buildtype $(usex debug debug plain)
- -Db_ndebug=$(usex debug false true)
- $(meson_use !minimal dri1)
- $(meson_use !minimal dri2)
- $(meson_use !minimal dri3)
- $(meson_use !minimal glamor)
- $(meson_use !minimal glx)
- $(meson_use udev)
- $(meson_use udev udev_kms)
- $(meson_use unwind libunwind)
- $(meson_use xcsecurity)
- $(meson_use selinux xselinux)
- $(meson_use xephyr)
- $(meson_use xnest)
- $(meson_use xorg)
- $(meson_use xvfb)
- -Ddocs=false
- -Ddrm=true
- -Ddtrace=false
- -Dipv6=true
- -Dhal=false
- -Dlinux_acpi=false
- -Dlinux_apm=false
- -Dsecure-rpc=false
- -Dsha1=libcrypto
- -Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
- )
-
- if [[ ${PV} == 9999 ]] ; then
- # Gone in 21.1.x, but not in master.
- emesonargs+=( -Dxwayland=false )
- fi
-
- if use systemd || use elogind; then
- emesonargs+=(
- -Dsystemd_logind=true
- $(meson_use suid suid_wrapper)
- )
- else
- emesonargs+=(
- -Dsystemd_logind=false
- -Dsuid_wrapper=false
- )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # The meson build system does not support install-setuid
- if ! use systemd && ! use elogind; then
- if use suid; then
- chmod u+s "${ED}"/usr/bin/Xorg
- fi
- fi
-
- if ! use xorg; then
- rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x || die
- fi
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}