summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-07-10 17:03:05 +0100
committerSam James <sam@gentoo.org>2021-05-28 01:09:08 +0000
commit637f5c37176bb8ab803447ff947d6c609006de00 (patch)
tree64a751af123ae249fd697bb7beac1247f0718aa1
parentdev-util/howdoi: Stabilize 2.0.15 ALLARCHES, #792429 (diff)
downloadgentoo-637f5c37.tar.gz
gentoo-637f5c37.tar.bz2
gentoo-637f5c37.zip
sci-geosciences/gpsbabel: 1.7.0 version bump, EAPI 7
GUI support is dropped because of multiple issues with resource paths. Closes: https://bugs.gentoo.org/689586 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14242 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/gpsbabel/Manifest1
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-use_system_shapelib.patch118
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-xmldoc.patch13
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.7.0.ebuild79
4 files changed, 211 insertions, 0 deletions
diff --git a/sci-geosciences/gpsbabel/Manifest b/sci-geosciences/gpsbabel/Manifest
index 5e230661d070..7a5ed8964bd7 100644
--- a/sci-geosciences/gpsbabel/Manifest
+++ b/sci-geosciences/gpsbabel/Manifest
@@ -1,2 +1,3 @@
DIST gpsbabel-1.5.4.tar.gz 9099765 BLAKE2B 339cc78f94fed883b73c9f74cc6e27dd214438ba86917079b27459f543a9cb360bd8ec12408af1f23b9114d774a3b8eeccfb6b9f4fa9e7dc73b63e11bac20d43 SHA512 5fdc3bc07ad52d6c1e3532b287dcb506aba612ae9bc8db393b4837d79d773d6e22ad31f8f8e65770ec52b1afbda556e452af20dada1e411de93ca6e18054225b
DIST gpsbabel.org-style3.css 2171 BLAKE2B 7fafef65e37d7c7cd183be06caafdbf303ac334484d7c09b4e668e8845f156f850b6f4cc6ac1aa081627367e999fa30d3505400e2aabd03fa117f6389318254f SHA512 33b843e0431de6d71a83c58da35ede28435e5a4746f59e52350c6e4451659e1b443d3c0dd52df1c68001e9937787820fb96afc363ec1ae7d23430bfed31dbc83
+DIST gpsbabel_1_7_0.tar.gz 16718984 BLAKE2B 8b824eb2a024f61e30abed80afe5e8ba8943771aff401171e7622eb3eb3d16cd2890964ccf0abfd28925d604087c57f013dc37bfac5d16ccdb97d2386a92ec29 SHA512 9df9d9cd65c3f33c0f39b4064e448834ad651ead368a3be3ea107f754ff0ac1500eb2111cddf43ecad61fe65b3412181842571fbba3387dd3dd36ff5c23e2911
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-use_system_shapelib.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-use_system_shapelib.patch
new file mode 100644
index 000000000000..744400906963
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-use_system_shapelib.patch
@@ -0,0 +1,118 @@
+diff --git a/Makefile.in b/Makefile.in
+index 5ace8da1..1acadf3e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -104,7 +104,7 @@ JEEPS=jeeps/gpsapp.o jeeps/gpscom.o \
+ # Extra modules in Jeeps that we don't use
+ # jeeps/gpsfmt.o jeeps/gpsinput.o jeeps/gpsproj.o
+
+-SHAPE=shapelib/shpopen.o shapelib/dbfopen.o shapelib/safileio.o
++SHAPE=-lshp
+
+ ZLIB=zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o zlib/inffast.o \
+ zlib/inflate.o zlib/infback.o zlib/inftrees.o zlib/trees.o \
+@@ -120,7 +120,7 @@ LIBOBJS = route.o waypt.o filter_vecs.o util.o vecs.o mkshort.o \
+ src/core/textstream.o \
+ src/core/usasciicodec.o \
+ src/core/xmlstreamwriter.o \
+- $(GARMIN) $(JEEPS) $(SHAPE) @ZLIB@ $(FMTS) $(FILTERS)
++ $(GARMIN) $(JEEPS) @ZLIB@ $(FMTS) $(FILTERS)
+ OBJS = main.o globals.o $(LIBOBJS) @FILEINFO@
+
+ DEPFILES = $(OBJS:.o=.d)
+@@ -153,10 +153,10 @@ toolinfo
+ all: gpsbabel$(EXEEXT)
+
+ gpsbabel$(EXEEXT): configure Makefile $(OBJS) @USB_DEPS@ @GPSBABEL_DEBUG@
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ gpsbabel-debug: $(OBJS) @USB_DEPS@
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(OBJS) $(SHAPE) @LIBS@ $(QT_LIBS) @USB_LIBS@ $(OUTPUT_SWITCH)$@
+
+ Makefile gbversion.h: Makefile.in config.status xmldoc/makedoc.in \
+ gbversion.h.in gui/setup.iss.in
+@@ -513,7 +513,7 @@ filter_vecs.o: filter_vecs.cc defs.h config.h zlib/zlib.h zlib/zconf.h \
+ ggv_bin.h globalsat_sport.h gpx.h src/core/xmlstreamwriter.h \
+ src/core/xmltag.h kml.h xmlgeneric.h legacyformat.h lowranceusr.h \
+ mynav.h nmea.h osm.h qstarz_bl_1000.h random.h shape.h \
+- shapelib/shapefil.h subrip.h unicsv.h src/core/textstream.h xcsv.h \
++ subrip.h unicsv.h src/core/textstream.h xcsv.h \
+ garmin_fs.h jeeps/gps.h jeeps/../defs.h jeeps/gpsport.h \
+ jeeps/gpsdevice.h jeeps/gpssend.h jeeps/gpsread.h jeeps/gpsutil.h \
+ jeeps/gpsapp.h jeeps/gpsprot.h jeeps/gpscom.h jeeps/gpsfmt.h \
+@@ -538,7 +538,7 @@ garmin.o: garmin.cc defs.h config.h zlib/zlib.h zlib/zconf.h formspec.h \
+ dg-100.h energympro.h garmin_fit.h geojson.h src/core/file.h ggv_bin.h \
+ globalsat_sport.h gpx.h src/core/xmlstreamwriter.h src/core/xmltag.h \
+ kml.h xmlgeneric.h legacyformat.h lowranceusr.h mynav.h nmea.h osm.h \
+- qstarz_bl_1000.h random.h shape.h shapelib/shapefil.h subrip.h \
++ qstarz_bl_1000.h random.h shape.h subrip.h \
+ unicsv.h src/core/textstream.h xcsv.h yahoo.h
+ garmin_device_xml.o: garmin_device_xml.cc defs.h config.h zlib/zlib.h \
+ zlib/zconf.h formspec.h inifile.h gbfile.h session.h \
+@@ -825,7 +825,7 @@ magproto.o: magproto.cc defs.h config.h zlib/zlib.h zlib/zconf.h \
+ dg-100.h energympro.h garmin_fit.h geojson.h src/core/file.h ggv_bin.h \
+ globalsat_sport.h gpx.h src/core/xmlstreamwriter.h src/core/xmltag.h \
+ kml.h xmlgeneric.h legacyformat.h lowranceusr.h mynav.h nmea.h osm.h \
+- qstarz_bl_1000.h random.h shape.h shapelib/shapefil.h subrip.h \
++ qstarz_bl_1000.h random.h shape.h subrip.h \
+ unicsv.h src/core/textstream.h xcsv.h garmin_fs.h jeeps/gps.h \
+ jeeps/../defs.h jeeps/gpsport.h jeeps/gpsdevice.h jeeps/gpssend.h \
+ jeeps/gpsread.h jeeps/gpsutil.h jeeps/gpsapp.h jeeps/gpsprot.h \
+@@ -841,7 +841,7 @@ main.o: main.cc defs.h config.h zlib/zlib.h zlib/zconf.h formspec.h \
+ garmin_fit.h geojson.h ggv_bin.h globalsat_sport.h gpx.h \
+ src/core/xmlstreamwriter.h src/core/xmltag.h kml.h xmlgeneric.h \
+ legacyformat.h lowranceusr.h mynav.h nmea.h osm.h qstarz_bl_1000.h \
+- random.h shape.h shapelib/shapefil.h subrip.h unicsv.h \
++ random.h shape.h subrip.h unicsv.h \
+ src/core/textstream.h xcsv.h garmin_fs.h jeeps/gps.h jeeps/../defs.h \
+ jeeps/gpsport.h jeeps/gpsdevice.h jeeps/gpssend.h jeeps/gpsread.h \
+ jeeps/gpsutil.h jeeps/gpsapp.h jeeps/gpsprot.h jeeps/gpscom.h \
+@@ -961,10 +961,7 @@ session.o: session.cc defs.h config.h zlib/zlib.h zlib/zconf.h formspec.h \
+ inifile.h gbfile.h session.h src/core/datetime.h src/core/optional.h
+ shape.o: shape.cc defs.h config.h zlib/zlib.h zlib/zconf.h formspec.h \
+ inifile.h gbfile.h session.h src/core/datetime.h src/core/optional.h \
+- shape.h format.h shapelib/shapefil.h
+-shapelib/dbfopen.o: shapelib/dbfopen.c shapelib/shapefil.h
+-shapelib/safileio.o: shapelib/safileio.c shapelib/shapefil.h
+-shapelib/shpopen.o: shapelib/shpopen.c shapelib/shapefil.h
++ shape.h format.h
+ skyforce.o: skyforce.cc defs.h config.h zlib/zlib.h zlib/zconf.h \
+ formspec.h inifile.h gbfile.h session.h src/core/datetime.h \
+ src/core/optional.h
+@@ -1059,7 +1056,7 @@ vecs.o: vecs.cc defs.h config.h zlib/zlib.h zlib/zconf.h formspec.h \
+ src/core/file.h ggv_bin.h globalsat_sport.h gpx.h \
+ src/core/xmlstreamwriter.h src/core/xmltag.h kml.h xmlgeneric.h \
+ legacyformat.h lowranceusr.h mynav.h nmea.h osm.h qstarz_bl_1000.h \
+- random.h shape.h shapelib/shapefil.h subrip.h unicsv.h \
++ random.h shape.h subrip.h unicsv.h \
+ src/core/textstream.h xcsv.h garmin_fs.h jeeps/gps.h jeeps/../defs.h \
+ jeeps/gpsport.h jeeps/gpsdevice.h jeeps/gpssend.h jeeps/gpsread.h \
+ jeeps/gpsutil.h jeeps/gpsapp.h jeeps/gpsprot.h jeeps/gpscom.h \
+diff --git a/shape.cc b/shape.cc
+index 933eb95a..f2ec5365 100644
+--- a/shape.cc
++++ b/shape.cc
+@@ -32,7 +32,7 @@
+
+ #include "defs.h"
+ #include "shape.h"
+-#include "shapelib/shapefil.h"
++#include <libshp/shapefil.h>
+
+
+ #if SHAPELIB_ENABLED
+diff --git a/shape.h b/shape.h
+index 0ce05af7..09931eff 100644
+--- a/shape.h
++++ b/shape.h
+@@ -27,7 +27,7 @@
+
+ #include "defs.h" // for arglist_t, ARGTYPE_STRING, Waypoint, route_head, CET_CHARSET_ASCII, FF_CAP_RW_ALL, ff_cap, ff_type, ff_type_file
+ #include "format.h" // for Format
+-#include "shapelib/shapefil.h" // for DBFHandle, SHPAPI_CALL, SHPHandle
++#include <libshp/shapefil.h> // for DBFHandle, SHPAPI_CALL, SHPHandle
+
+
+ #if SHAPELIB_ENABLED
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-xmldoc.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-xmldoc.patch
new file mode 100644
index 000000000000..56c60a553485
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.7.0-xmldoc.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.in 2017-01-21 00:32:50.921546762 +0100
++++ b/Makefile.in 2017-01-21 00:55:45.362728521 +0100
+@@ -278,8 +278,8 @@
+ --stringparam html.cleanup "1" \
+ --stringparam make.clean.html "1" \
+ --stringparam html.valid.html "1" \
+- --stringparam html.stylesheet \
+- "https://www.gpsbabel.org/style3.css" \
++ --nonet \
++ --stringparam html.stylesheet "gpsbabel.org-style3.css" \
+ http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+ xmldoc/readme.xml
+
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.7.0.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.7.0.ebuild
new file mode 100644
index 000000000000..51a9005c067e
--- /dev/null
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.7.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+MY_PV="${PV//./_}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="GPS waypoints, tracks and routes converter"
+HOMEPAGE="https://www.gpsbabel.org/ https://github.com/gpsbabel/gpsbabel"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz
+ doc? ( https://www.gpsbabel.org/style3.css -> gpsbabel.org-style3.css )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/expat
+ dev-qt/qtcore:5
+ sci-libs/shapelib:=
+ sys-libs/zlib
+ virtual/libusb:0
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-xmldoc.patch
+ "${FILESDIR}"/${P}-use_system_shapelib.patch
+)
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ default
+
+ # ensure bundled libs are not used
+ rm -r shapelib zlib || die
+ # remove prerequisite zlib/zlib.h
+ sed -i -e "s: zlib\/[a-z]*\.h::g" Makefile.in || die
+ # remove failing test (fixed by f91d28bf)
+ rm testo.d/arc-project.test || die
+
+ use doc && cp "${DISTDIR}/gpsbabel.org-style3.css" "${S}"
+}
+
+src_configure() {
+ econf \
+ $(use_with doc doc "${S}"/doc/manual) \
+ QMAKE=$(qt5_get_bindir)/qmake \
+ --with-zlib=system
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ perl xmldoc/makedoc || die
+ emake gpsbabel.html
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${S}"/${PN}.html "${S}"/${PN}.org-style3.css )
+
+ default
+}