summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-09-27 23:17:56 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-09-27 23:18:31 +0200
commit63c279b7c4cb63a60f278c2c6dba20f92ba057d4 (patch)
tree12a4f11278aa3d49a04aff59cf5f2c5c51630c20
parentnet-p2p/nicotine+: 3.1.1 version bump. (diff)
downloadgentoo-63c279b7.tar.gz
gentoo-63c279b7.tar.bz2
gentoo-63c279b7.zip
media-video/vidcutter: 6.0.5.1: version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--media-video/vidcutter/Manifest1
-rw-r--r--media-video/vidcutter/vidcutter-6.0.5.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-video/vidcutter/Manifest b/media-video/vidcutter/Manifest
index 3bad55748d40..67eb2c410646 100644
--- a/media-video/vidcutter/Manifest
+++ b/media-video/vidcutter/Manifest
@@ -1 +1,2 @@
+DIST vidcutter-6.0.5.1.tar.gz 9909274 BLAKE2B 063c20f6ae0565b0f3a160b5ee298aae05b2ee1876cd4c73d9f37578a9e86a872353c3e2b7b1b6302db3d5a876139bfb19d50bf7cb4dd18e6e1d1a1ca3587fbd SHA512 f2ea2a86d9eaa3c6593e785daad6869c151baa1add529c9edaf2282f7acad762fbb29804790aece5e4fcd89e9e9bc77f61d1f0b68a1b1f3ecf58951ee8f200e9
DIST vidcutter-6.0.5.tar.gz 9911435 BLAKE2B 2d901768064b7c3b7444289db84e8f8d6e179d915b04f870a6b397f0d905c6b4ecab0768d045a8c1aa43b3bf7bccb2dcd60e9c043595f2aaf857ce657ec997f8 SHA512 b4a0e0cc3132038e9216f05117768695ba30840f04251c60561b7555cde9064efcf12440c801c834c2160d5b5acad011dc31055d9547269a5689361c875bca80
diff --git a/media-video/vidcutter/vidcutter-6.0.5.1.ebuild b/media-video/vidcutter/vidcutter-6.0.5.1.ebuild
new file mode 100644
index 000000000000..8ec68eb7ef9e
--- /dev/null
+++ b/media-video/vidcutter/vidcutter-6.0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
+HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
+
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
+else
+ SRC_URI="https://github.com/ozmartian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=media-video/mpv-0.25[libmpv]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-5.7[dbus,multimedia,widgets,${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-video/ffmpeg[X,encode]
+ media-video/mediainfo"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+}