summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 09:34:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 09:34:26 +0200
commit63c72d6d4cf542e5318393475c111b3c08ccb797 (patch)
tree3be57234e9a068ca62a49932c632afeb2d6fe2c6
parentwww-apps/klaus: Remove old (diff)
downloadgentoo-63c72d6d4cf542e5318393475c111b3c08ccb797.tar.gz
gentoo-63c72d6d4cf542e5318393475c111b3c08ccb797.tar.bz2
gentoo-63c72d6d4cf542e5318393475c111b3c08ccb797.zip
www-apps/roundup: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-apps/roundup/Manifest2
-rw-r--r--www-apps/roundup/files/roundup-2.0.0-test-pyjwt.patch91
-rw-r--r--www-apps/roundup/roundup-2.0.0-r1.ebuild53
-rw-r--r--www-apps/roundup/roundup-2.1.0-r1.ebuild48
4 files changed, 0 insertions, 194 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
index 4eca53c9974b..d0fc2e60a971 100644
--- a/www-apps/roundup/Manifest
+++ b/www-apps/roundup/Manifest
@@ -1,3 +1 @@
-DIST roundup-2.0.0.tar.gz 3495554 BLAKE2B 98b7cbfebe969411282ddf6b4bd7b94ea1efb7b1d929daf44ae5f30dc23c05cb327d0f4653b22a5594f7b198dd16a172c45568a15f8704b187cd4c355455ca9c SHA512 5adb0d96be260e70fe098fd37af27bd0abee38cb8fde4ba2e130d2caac7f64af86a3b0ab09de931a693dca8bfbe15c68444db343ccf718d9d25576d49c6d6cbf
-DIST roundup-2.1.0.tar.gz 3586805 BLAKE2B a5ec6cad38e252e2ffd4d3de4def9b8414ee8758503aa29681d80b36ac62a15700e21e762c6833ce6f795f71a7a1c75c4d9ae30c49c5f038317e5d3fdc58b11d SHA512 ebc047d944f1118b30141b873d91e580d415f1e7c9331875d6efb18cf42c9121163c801b1559d02890165bfd2e5a894c5990b587ce7766b2bf4724745ca9e760
DIST roundup-2.2.0.tar.gz 3722236 BLAKE2B f9f36ff2a49c769dcce38dd59fd88825cb3a6560fbfc2a7bbf6d2abf1388bb328da5aa7de2934ae2469163bb4f125b4438b07f1eff9082458768012b4eda7687 SHA512 dbaf7c4a5e7fb75f0e401f39962c8f5a3b088036a0f2c9efb2910f3941df35df6c345c2051c37cbdcc9a2049d82d09bcb4e15b368f8c4c77fa4b4bf80c6dc844
diff --git a/www-apps/roundup/files/roundup-2.0.0-test-pyjwt.patch b/www-apps/roundup/files/roundup-2.0.0-test-pyjwt.patch
deleted file mode 100644
index 74f71dab57ff..000000000000
--- a/www-apps/roundup/files/roundup-2.0.0-test-pyjwt.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-# HG changeset patch
-# User John Rouillard <rouilj@ieee.org>
-# Date 1609557405 18000
-# Fri Jan 01 22:16:45 2021 -0500
-# Node ID a2fbd3592322379f0c54a75446d2a282c6f40075
-# Parent e3edb0b44d94df71f46094cdda9ed4e51e6c1de4
-pyjwt 2.00 changed return type of jwt.encode from byte to str
-
-Need to change tests to only do b2s conversion if using version before
-2.0.0. Note 2.0.0 drops support for python 2. Also it is not
-installed for the python 3.4 ci test by pip install.
-
-diff --git a/test/rest_common.py b/test/rest_common.py
---- a/test/rest_common.py
-+++ b/test/rest_common.py
-@@ -68,6 +68,8 @@ class TestCase():
- url_pfx = 'http://tracker.example/cgi-bin/roundup.cgi/bugs/rest/data/'
-
- def setUp(self):
-+ from packaging import version
-+
- self.dirname = '_test_rest'
- # set up and open a tracker
- # Set optimize=True as code under test (Client.main()::determine_user)
-@@ -162,50 +164,58 @@ class TestCase():
- 'iat': now_ts,
- 'exp': plus1min_ts,
- }
-+
-+ # in version 2.0.0 and newer jwt.encode returns string
-+ # not bytestring. So we have to skip b2s conversion
-
-+ if version.parse(jwt.__version__) >= version.parse('2.0.0'):
-+ tostr = lambda x: x
-+ else:
-+ tostr = b2s
-+
- self.jwt = {}
- self.claim = {}
- # generate invalid claim with expired timestamp
- self.claim['expired'] = copy(claim)
- self.claim['expired']['exp'] = expired_ts
-- self.jwt['expired'] = b2s(jwt.encode(self.claim['expired'], secret,
-+ self.jwt['expired'] = tostr(jwt.encode(self.claim['expired'], secret,
- algorithm='HS256'))
-
- # generate valid claim with user role
- self.claim['user'] = copy(claim)
- self.claim['user']['exp'] = plus1min_ts
-- self.jwt['user'] = b2s(jwt.encode(self.claim['user'], secret,
-+ self.jwt['user'] = tostr(jwt.encode(self.claim['user'], secret,
- algorithm='HS256'))
- # generate invalid claim bad issuer
- self.claim['badiss'] = copy(claim)
- self.claim['badiss']['iss'] = "http://someissuer/bugs"
-- self.jwt['badiss'] = b2s(jwt.encode(self.claim['badiss'], secret,
-+ self.jwt['badiss'] = tostr(jwt.encode(self.claim['badiss'], secret,
- algorithm='HS256'))
- # generate invalid claim bad aud(ience)
- self.claim['badaud'] = copy(claim)
- self.claim['badaud']['aud'] = "http://someaudience/bugs"
-- self.jwt['badaud'] = b2s(jwt.encode(self.claim['badaud'], secret,
-+ self.jwt['badaud'] = tostr(jwt.encode(self.claim['badaud'], secret,
- algorithm='HS256'))
- # generate invalid claim bad sub(ject)
- self.claim['badsub'] = copy(claim)
- self.claim['badsub']['sub'] = str("99")
-- self.jwt['badsub'] = b2s(jwt.encode(self.claim['badsub'], secret,
-+ self.jwt['badsub'] = tostr(jwt.encode(self.claim['badsub'], secret,
- algorithm='HS256'))
- # generate invalid claim bad roles
- self.claim['badroles'] = copy(claim)
- self.claim['badroles']['roles'] = [ "badrole1", "badrole2" ]
-- self.jwt['badroles'] = b2s(jwt.encode(self.claim['badroles'], secret,
-+ self.jwt['badroles'] = tostr(jwt.encode(self.claim['badroles'], secret,
- algorithm='HS256'))
- # generate valid claim with limited user:email role
- self.claim['user:email'] = copy(claim)
- self.claim['user:email']['roles'] = [ "user:email" ]
-- self.jwt['user:email'] = b2s(jwt.encode(self.claim['user:email'], secret,
-+ self.jwt['user:email'] = tostr(jwt.encode(self.claim['user:email'], secret,
- algorithm='HS256'))
-
- # generate valid claim with limited user:emailnorest role
- self.claim['user:emailnorest'] = copy(claim)
- self.claim['user:emailnorest']['roles'] = [ "user:emailnorest" ]
-- self.jwt['user:emailnorest'] = b2s(jwt.encode(self.claim['user:emailnorest'], secret,
-+ self.jwt['user:emailnorest'] = tostr(jwt.encode(self.claim['user:emailnorest'], secret,
- algorithm='HS256'))
-
- self.db.tx_Source = 'web'
diff --git a/www-apps/roundup/roundup-2.0.0-r1.ebuild b/www-apps/roundup/roundup-2.0.0-r1.ebuild
deleted file mode 100644
index 99977a136bf5..000000000000
--- a/www-apps/roundup/roundup-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-MY_P=${P/_/}
-
-DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
-HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT ZPL"
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- tz? ( dev-python/pytz[$PYTHON_USEDEP] )
- sqlite? ( $(python_gen_impl_dep sqlite) )
- mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
- postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
- xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
- whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
- ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
- jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
- pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
- markdown? (
- dev-python/markdown[$PYTHON_USEDEP]
- dev-python/markdown2[$PYTHON_USEDEP]
- dev-python/mistune[$PYTHON_USEDEP]
- )"
-
-DOCS="CHANGES.txt doc/*.txt"
-PATCHES=(
- "${FILESDIR}/${P}-test-pyjwt.patch"
-)
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- rm -r "${ED}"/usr/share/doc/${PN} || die
-}
-
-pkg_postinst() {
- ewarn "See installation.txt for initialisation instructions."
- ewarn "See upgrading.txt for upgrading instructions."
-}
diff --git a/www-apps/roundup/roundup-2.1.0-r1.ebuild b/www-apps/roundup/roundup-2.1.0-r1.ebuild
deleted file mode 100644
index e891f9603add..000000000000
--- a/www-apps/roundup/roundup-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
-HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
-
-LICENSE="MIT ZPL"
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- tz? ( dev-python/pytz[$PYTHON_USEDEP] )
- sqlite? ( $(python_gen_impl_dep sqlite) )
- mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
- postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
- xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
- whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
- ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
- jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
- pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
- markdown? (
- || (
- dev-python/markdown[$PYTHON_USEDEP]
- dev-python/markdown2[$PYTHON_USEDEP]
- dev-python/mistune[$PYTHON_USEDEP]
- )
- )"
-
-DOCS="CHANGES.txt doc/*.txt"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- rm -r "${ED}"/usr/share/doc/${PN} || die
-}
-
-pkg_postinst() {
- ewarn "See installation.txt for initialisation instructions."
- ewarn "See upgrading.txt for upgrading instructions."
-}