summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-06 01:18:16 -0500
committerSam James <sam@gentoo.org>2024-03-06 06:29:59 +0000
commit63c79d85f42813299f878b3f67c039e2b23994f3 (patch)
treec28be3e7ec843c77d1277413f0e6f5653c8db671
parentdev-lang/snobol: filter LTO, no SA (diff)
downloadgentoo-63c79d85f42813299f878b3f67c039e2b23994f3.tar.gz
gentoo-63c79d85f42813299f878b3f67c039e2b23994f3.tar.bz2
gentoo-63c79d85f42813299f878b3f67c039e2b23994f3.zip
app-i18n/scim-uim: re-run autoreconf to fix LTO
The 2009 era distfile is so old that it probably has many bugs. We are particularly concerned by nm detection failing under LTO causing: ``` generating symbol list for `uim.la' /usr/bin/nm -B .libs/uim_la-scim_uim_imengine.o | | /usr/bin/sed 's/.* //' | sort | uniq > .libs/uim.exp ../libtool: 1: eval: Syntax error: "|" unexpected ``` Closes: https://bugs.gentoo.org/854672 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
index 8b9fe22e0718..dc2d5aabb92f 100644
--- a/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
+++ b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses uim as backend"
HOMEPAGE="http://www.scim-im.org/"
SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
@@ -23,6 +25,12 @@ PATCHES=(
"${FILESDIR}"/${P}-uim-1.5.patch
)
+src_prepare() {
+ default
+ # update the 2007 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}