summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-01 23:48:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-02 00:35:48 +0200
commit63e7f70de010945b04f0666c2f18704d552c2b6e (patch)
treef673c8846f5fa1594212d4cf9ebe7c7280755d63
parentsci-mathematics/why3: drop old 1.5.0-r1 (diff)
downloadgentoo-63e7f70de010945b04f0666c2f18704d552c2b6e.tar.gz
gentoo-63e7f70de010945b04f0666c2f18704d552c2b6e.tar.bz2
gentoo-63e7f70de010945b04f0666c2f18704d552c2b6e.zip
sci-mathematics/flocq: bump to 4.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/flocq/Manifest1
-rw-r--r--sci-mathematics/flocq/flocq-4.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-mathematics/flocq/Manifest b/sci-mathematics/flocq/Manifest
index f04ae7c7ad49..094cfd9c64ee 100644
--- a/sci-mathematics/flocq/Manifest
+++ b/sci-mathematics/flocq/Manifest
@@ -1 +1,2 @@
DIST flocq-4.1.0.tar.gz 447412 BLAKE2B 1b993a0e86bd440602b16b94ed5aff4b95a3c732eca87c683d239702b285dee8eaaf7dad77f730ae4929bb24504e5fd12b9a181d48efac4c3db7f0606637c018 SHA512 677e0de1406b3c7e5504d114a5b18ec07c719bbad79a2cfb750ac309fd5ab09be5493afdb1786b5a188cece59fddcd4167e28bf3be4facbdea8fe3b11cdf1ab1
+DIST flocq-4.1.1.tar.gz 450132 BLAKE2B 00821a3e135156640320d1afd548bc1912953bba64cc675b7b6c94b4e3c792c444bfbb4ef1a3352adefa466548083e32c2b1e4b38747dcbc6ac6de6d72250a74 SHA512 7076b8d5e33b8225e0124b9f66f4e3e1ed3e30804c5bca28e30d5e176c1b8c5c3d777a28c243fada17ab4ed32f580c6d606b11f045d48f7acb15e03db59870c4
diff --git a/sci-mathematics/flocq/flocq-4.1.1.ebuild b/sci-mathematics/flocq/flocq-4.1.1.ebuild
new file mode 100644
index 000000000000..f70775d38f46
--- /dev/null
+++ b/sci-mathematics/flocq/flocq-4.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+DESCRIPTION="Formalization of floating-point arithmetic for the Coq proof assistant"
+HOMEPAGE="http://flocq.gforge.inria.fr/
+ https://gitlab.inria.fr/flocq/flocq/"
+SRC_URI="https://flocq.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ >=sci-mathematics/coq-8.12:=
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ dodoc AUTHORS INSTALL.md NEWS.md README.md
+
+ insinto /usr/share/${PN}
+ doins -r examples
+}