summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 09:52:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:26:58 +0200
commit63edffb29fc92a2e49c7f8a41e57b577789dfe00 (patch)
tree8a621df5ba894e63af8dde4f2bb2a5693fd9a821
parentdev-python/imageio: Bump to 2.19.0 (diff)
downloadgentoo-63edffb29fc92a2e49c7f8a41e57b577789dfe00.tar.gz
gentoo-63edffb29fc92a2e49c7f8a41e57b577789dfe00.tar.bz2
gentoo-63edffb29fc92a2e49c7f8a41e57b577789dfe00.zip
dev-python/python-email-validator: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-email-validator/Manifest1
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-email-validator/Manifest b/dev-python/python-email-validator/Manifest
index 9dc0ade0f55c..269f89a55846 100644
--- a/dev-python/python-email-validator/Manifest
+++ b/dev-python/python-email-validator/Manifest
@@ -1,2 +1,3 @@
DIST python-email-validator-1.1.3.tar.gz 19863 BLAKE2B 10700b4c6a48c50095045b6e3c9218cd565776b26e17c1c043633e208b9fbd346162cedaa4a1116ec2fccf63b4383438c7e1aef6faf9d2ead5512af7f934675c SHA512 d9087bf56783daf389909e13652a9db8f0408badf454f6239aa20f6a5e9510619d3662cf1567a03d0b14c4bbe81644509cd12975b2aa1b544d644b6c2b2854f4
DIST python-email-validator-1.2.0.tar.gz 22603 BLAKE2B cc2364e903cf4f1c3983ad4764a46a317188353899f8cd929c72c60387a25a819405b0cf8253488fa11e4ce9be48df98c64bdc0c3df1664a74c2e6c9c4389e6a SHA512 3c4f87e0992615ae4d1f44e6e0fe9909b43d5810f2aca96129f5ee4dcadac7b4ec5a979dbf6e03f60b8bda2ff0d7cf87f9276c4b4c624e2d036627e2d5d8afad
+DIST python-email-validator-1.2.1.gh.tar.gz 24348 BLAKE2B 7cd19c07bd0b8c467c0f0ec15376f0677305c6025eff5a86854dfd7cad3fe6971e218e724d86d4040af3f590fe5e841e469dea7dc8526031dccb494845848630 SHA512 e758518ef114e08cca0f83c681e6ff7ec6fad54c1e0bba727ee0f8917e93040ed3873ba0207e21a4830208d98637937294c5c28d67c317dc4ad3351c7d3f99a4
diff --git a/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild b/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild
new file mode 100644
index 000000000000..dd6dc9a517db
--- /dev/null
+++ b/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A robust email syntax and deliverability validation library"
+HOMEPAGE="
+ https://github.com/JoshData/python-email-validator/
+ https://pypi.org/project/email-validator/
+"
+SRC_URI="
+ https://github.com/JoshData/python-email-validator/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # these tests rely on access to gmail.com
+ tests/test_main.py::test_deliverability_found
+ tests/test_main.py::test_deliverability_fails
+ # these tests rely on example.com being resolvable
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@example.com]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example.com]"
+ tests/test_main.py::test_validate_email__with_caching_resolver
+)