summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-30 04:25:13 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-30 04:27:06 +1000
commit641226130f6ee8b1e390db562276c6f9045193ea (patch)
tree41a0a890b6fc3c94a3d41ae062ab4e84e6aa8c5f
parentdev-python/requests-mock: Bump (diff)
downloadgentoo-64122613.tar.gz
gentoo-64122613.tar.bz2
gentoo-64122613.zip
dev-db/sqliteman: add patch to solve build failure on uclibc caused by underlinking
Gentoo-bug: 587076 Package-Manager: portage-2.3.0
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch19
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild3
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch
new file mode 100644
index 000000000000..a9bf4f4f9528
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch
@@ -0,0 +1,19 @@
+Resolves underlinking issue causing build failure on uclibc.
+
+Author: René Rhéaume <rene.rheaume@gmail.com>
+Gentoo-bug: 587076
+
+--- a/sqliteman/CMakeLists.txt
++++ b/sqliteman/CMakeLists.txt
+@@ -183,7 +183,10 @@ IF (WIN32)
+ # don't use console subsystem
+ IF (MINGW)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} "-mwindows")
+- ENDIF (MINGW)
++ ENDIF (MINGW)
++ELSE (WIN32)
++ FIND_PACKAGE(Threads)
++ TARGET_LINK_LIBRARIES(${EXE_NAME} ${CMAKE_THREAD_LIBS_INIT})
+ ENDIF (WIN32)
+
+
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild
index edadcb76a462..e10a0cab9a74 100644
--- a/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,6 +23,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
DOCS=( AUTHORS README )
+PATCHES=( "${FILESDIR}/${P}-lpthread.patch" )
src_prepare() {
# remove bundled lib