summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-22 07:21:02 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-22 07:22:23 +0100
commit6428b2606f6e26159390ae21efd958fd1df883fe (patch)
tree876ad2a0e27faf18caaf13c35989693c3b5f9619
parentdev-python/pyopenssl: Tested on ~amd64-fbsd (diff)
downloadgentoo-6428b260.tar.gz
gentoo-6428b260.tar.bz2
gentoo-6428b260.zip
dev-python/service_identity: Enable tests
-rw-r--r--dev-python/service_identity/Manifest1
-rw-r--r--dev-python/service_identity/service_identity-17.0.0-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/service_identity/Manifest b/dev-python/service_identity/Manifest
index 8742e13d7bcf..e0c1bc8c06f3 100644
--- a/dev-python/service_identity/Manifest
+++ b/dev-python/service_identity/Manifest
@@ -1,3 +1,4 @@
DIST service_identity-14.0.0.tar.gz 26033 BLAKE2B 1cc3e0f686f79abb903a2b06e429e4f5db96719a670b371ea98a7bb52269387fb2c1beb1fcfacdc278ee628bc445a7d2879526174f3111ab874c002d2248430b SHA512 d504ad388defb38a86ca82c8ff9582dbb664a929e4b4ee7f6732b2da5326c33b1764384a8d849972f83ae7800c775daf90c1f3fbc61b8d2c29294f44c7cd36d2
DIST service_identity-16.0.0.tar.gz 30270 BLAKE2B ced67dc2be04db57d79c60f4fa0e330b09ec1315986206911b807b65a7b97e313ea376de74501e938aa77f2e02a693669539f899de8ec817848b24c0c03f42dd SHA512 0ffa28b3dece2415a058ec159e4f85f3e86c0de520ed5d6933ec49edca91ccc79a57893ace40d5441455791433828ab55a939e90335dfdee8582627e33a896ae
+DIST service_identity-17.0.0.gh.tar.gz 29078 BLAKE2B 4fcf8ab697d87c13268da880f8d8caf59ad2d5d8734b7a8c65100fdeca81a0261e8c88d21b7c91bbd42fc1e271bd4440826254003eaedac17f66c09312a9f15b SHA512 3824cb473420a5ce6779fd35ff931189ed68286ad1f7f2936e3253a785cd76a77bbb95210a4a5fde1b1ef0c8d9c762b8e89ab44dce60ee43e34b2553ab78b5aa
DIST service_identity-17.0.0.tar.gz 23502 BLAKE2B 49218eb0c4021d7a69b09ca79d60b3f421c3c35b606de9bb47812e949b0f1284f0fed5bd9e18615bd569ea31b426339fb8ecacaa7e30cca0cb0abf488bea02f7 SHA512 4ba35166b520bbeb391c047b5fcca1dbf137a65e0624c92a6b6c2229f9521627be95195a8e502cbcc5a887d904598b1f0e63b47f6a38ee9f78afe13278d692ec
diff --git a/dev-python/service_identity/service_identity-17.0.0-r1.ebuild b/dev-python/service_identity/service_identity-17.0.0-r1.ebuild
new file mode 100644
index 000000000000..5834a6b947ef
--- /dev/null
+++ b/dev-python/service_identity/service_identity-17.0.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Service identity verification for pyOpenSSL"
+HOMEPAGE="https://github.com/pyca/service_identity"
+SRC_URI="https://github.com/pyca/service_identity/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v -v -x || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}