summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-26 12:47:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-27 00:19:21 +0100
commit64482bb14deec93d807995b005753eb1bf6392ba (patch)
tree68bd7107b920fb1b6fee7ba2a3391c16d198c16c
parentgames-emulation/dosbox-staging: update Manifest (diff)
downloadgentoo-64482bb14deec93d807995b005753eb1bf6392ba.tar.gz
gentoo-64482bb14deec93d807995b005753eb1bf6392ba.tar.bz2
gentoo-64482bb14deec93d807995b005753eb1bf6392ba.zip
dev-cpp/libcmis: update EAPI 7 -> 8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 2cccc1fd0ee9..10de5182674b 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,25 +1,32 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
inherit git-r3
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit autotools flag-o-matic
+inherit autotools
DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0.5"
+IUSE="man test tools"
-IUSE="man static-libs test tools"
+RESTRICT="test"
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/libxml2
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
man? (
@@ -31,14 +38,6 @@ BDEPEND="
dev-util/cppunit
)
"
-DEPEND="
- dev-libs/boost:=
- dev-libs/libxml2
- net-misc/curl
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
src_prepare() {
default
@@ -46,14 +45,10 @@ src_prepare() {
}
src_configure() {
- # bug 618778
- append-cxxflags -std=c++14
-
local myeconfargs=(
--program-suffix=-$(ver_cut 1-2)
--disable-werror
$(use_with man)
- $(use_enable static-libs static)
$(use_enable test tests)
$(use_enable tools client)
)