summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-29 07:57:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-29 08:17:03 +0200
commit6468512d8c9ae51fa670770beecd2c905247ed6c (patch)
tree62868cb122ac14ff3f0a92b291806501f0ddeacf
parentdev-python/boto3: Bump to 1.22.3 (diff)
downloadgentoo-6468512d8c9ae51fa670770beecd2c905247ed6c.tar.gz
gentoo-6468512d8c9ae51fa670770beecd2c905247ed6c.tar.bz2
gentoo-6468512d8c9ae51fa670770beecd2c905247ed6c.zip
app-admin/awscli: Bump to 1.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.23.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6a21e73b043f..7b2a28767984 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,5 +1,6 @@
DIST aws-cli-1.23.0.gh.tar.gz 2197192 BLAKE2B 414646dc2e4ea5638185ab53e78e8de4403ff10084ce15ebbf5c67249722226769cd0eb02892ffb9bae5440956200417eb74393c6f393ec52a313fc55d9960a2 SHA512 27380033b02e88c6d022e8c33f0e4339e3c67b00cd2b7e92620ef2581e1ff8f55b55123aa4d4a24028c941f6ad60a0fe3e8f6d14d5a970163a97a2adb9ae93d6
DIST aws-cli-1.23.1.gh.tar.gz 2197883 BLAKE2B 1e43b70319d58e689e2ccad38e0b6177c870888c798966a34837f93c340e39b2ac5d351a38e8bed830312931b5764ea6b390a50da9735864dce61a1666da7899 SHA512 a105f8fcfdd36467cc0f328c70a505458c228f69735b23306042944618fbb508efc061c671f7eb743efd13acbe5e4b6ee96205ff14b7f98685fa3f81b3958f9f
DIST aws-cli-1.23.2.gh.tar.gz 2199816 BLAKE2B 7aef7ea7efb2b37b8d63fd64b2e86129d7588aa1d9b2a34d243cf99564be8dee282c4e48e08e900d0988dfe08eaa8af08cb7e79dee235354efb216db5bcb9996 SHA512 04c6324f02afe187c93827433184fbe0d2b82add88488becdcaedb904ddb10332dc93e0c995ef9467216ac19955318bdd9f128022aaa63245bc361ad2061bdc9
+DIST aws-cli-1.23.3.gh.tar.gz 2200496 BLAKE2B 4c264c2e551af9df2f84d405a08f1e386da3da48b1b8c6be285bbcbf8d9cd05429828ccbf52a606f0a8e50d440c307d1b03ebf2cf8ca58460384fda4352cb8e2 SHA512 8aa1a0005a4c8be400d9684a92af412815007c8c6f4f7b74915781e8dbb1182de450db194d41a5fdeab68ee5bf9c49329927284305ac76171719e8a3325a9f48
DIST awscli-1.22.101.tar.gz 2196746 BLAKE2B 590938e722e9dff00bcdb4a266f7063bca4e890f5db5e52b56ed710f5777c6e9de3cfe1423cee9ae2cea74d624bdd665cd8af487aec1ba4e650279c700540545 SHA512 ab99b95c5252c48a7a1d10adb053c56e27139e35bb512ce854e90a433e2d028aed2a88f72e518b0f723dea147919961e7cc7f5d980342206e629f750b0fe77ec
DIST awscli-1.22.97.tar.gz 2193983 BLAKE2B f2e0efbb2332d4c405d5e97ba35426424d932a013114492890018d3419349e23aa3c8301f6c29bd8eaa662145b07ceaa30c22e41aad38012ca307400075600ca SHA512 00426aab19fcdf3241850b09d4d5dd6a1460e3ec9baa37cf203068dc6ca0fddd4fe3de7e4e93e8e6539608351777e00692bb8b9d2c362ceeacc55071cd53f422
diff --git a/app-admin/awscli/awscli-1.23.3.ebuild b/app-admin/awscli/awscli-1.23.3.ebuild
new file mode 100644
index 000000000000..c9a5eb0d75aa
--- /dev/null
+++ b/app-admin/awscli/awscli-1.23.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}