summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-06 19:50:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-06 20:54:27 +0300
commit6478ee3360972c5fac5e6f1d048f1b3dcb21dd37 (patch)
treee11a2a4d2a1d861617fbc63c0895e4c9b4ca24a2
parentdev-python/astroid: add 2.12.8 (diff)
downloadgentoo-6478ee33.tar.gz
gentoo-6478ee33.tar.bz2
gentoo-6478ee33.zip
dev-python/zeroconf: add 0.39.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.39.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 61fabf74b706..966bcb242f32 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,4 @@
DIST python-zeroconf-0.38.6.gh.tar.gz 134795 BLAKE2B 839d59d7c46d9ab16145e37bb58acc7a71072b00507ee0ae8325fea9a3ebc0e567f9e257937675f8eaf44095c7449f96e6bc42b82d34f75a39cc87fd29be2766 SHA512 274db525751191b0188a4f00505c795420f975de3f714f84f2207271ff484bb5de1c881c0ed00b1ad3a6265d5d461519cf46041ab907026d9e6937844bbab6af
DIST python-zeroconf-0.38.7.gh.tar.gz 134866 BLAKE2B 060ffdc45d4ec8092cd278b99a74561fd1ea06aba3cdecadbd35c1c5e3f608befe3ced18009d8d64c5b37388ee57900b4b00a44c90d87923f259e798da5bb962 SHA512 a0ab90f30b843bc889daf95eab6d806a5e3fb4ffe5e3857c435f14a85de7b659b8386159f6428f05a34f2e3010f4582f7d3a55bbd6e6ede0008247821f666707
DIST python-zeroconf-0.39.0.gh.tar.gz 135121 BLAKE2B 708f641934b1d155a464f532894e6f3ba3b83c57063b903eae23abcfaf76974920286a9ddcabc53d0211df21b247303c23b2ee36f78ccf809001395f0d1002a7 SHA512 401808d51b58905937b0c2f924bce6a9ae38f331f2faf7a0258bfcbc245ec618deaf1a707d22c47792d964a49a2036af5d2ab02438b001b228611a5855db897f
+DIST python-zeroconf-0.39.1.gh.tar.gz 135252 BLAKE2B 82efa3e39b6e18b9d73b45958190c1d76978231842c1f61ff4519b9a763fb2c1564dae9c0b1d31109e291acc966127cfae9fa02400f1695e97dcc1b0e5a509f7 SHA512 3e1bc4bd48b77bce711f8b49b9cdce1769d7af72094c9ebc161ecb833fe90c7bd36ec5b9fc35c524ddd8c30a67af5937f188c81cf3a251d80c0e71f4b7c3add7
diff --git a/dev-python/zeroconf/zeroconf-0.39.1.ebuild b/dev-python/zeroconf/zeroconf-0.39.1.ebuild
new file mode 100644
index 000000000000..e803d214a211
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.39.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)