summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-01-15 15:31:01 +0000
committerMarek Szuba <marecki@gentoo.org>2024-01-15 15:31:07 +0000
commit6486bf82209e475faa36a20f2e0a5ab0fea4120f (patch)
tree652aba3ed7e4cfb3e624036fdfec74d1ce93ed10
parentdev-db/timescaledb: add 2.13.1 (diff)
downloadgentoo-6486bf82209e475faa36a20f2e0a5ab0fea4120f.tar.gz
gentoo-6486bf82209e475faa36a20f2e0a5ab0fea4120f.tar.bz2
gentoo-6486bf82209e475faa36a20f2e0a5ab0fea4120f.zip
net-p2p/syncthing: drop 1.26.1
No versions vulnerable to CVE-2023-49295 left in the tree. Bug: https://bugs.gentoo.org/922059 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-1.26.1.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index bb3c9f6bc456..6eccaa287843 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,2 +1 @@
-DIST syncthing-1.26.1.tar.gz 15020478 BLAKE2B 679536a4a5cbd5299458253b69308fbffcd20fe25273d05ae91c7ff80af98e486af277855fc6d66a7487b88b3fe532be5f85766dac4c9ab766d199b824de5740 SHA512 932c0faf1d7b9af67474ac4729d867b7495a023459aa59ed5f4210b5cba5ef5561bc82020f6e202dda549086db06c20844e7e5541f136892a8916c25439c754d
DIST syncthing-1.27.2.tar.gz 14967954 BLAKE2B 8f033e18679f7accc3d461566da88fa45b2e1c8dc1b1b5ace2732e3987d82e8d458c42dc3571f7d1199cf35667be72fcf81b65efa9cd2dac65297bc86b03e284 SHA512 6b6bd57268b32b5db2377cf813229de978e26de606ac3bf2b515ddb35fd8131fafdb88abbfac1cb7d0f443224538cca7a6eba64f4bd737135f5a1c98e76439f9
diff --git a/net-p2p/syncthing/syncthing-1.26.1.ebuild b/net-p2p/syncthing/syncthing-1.26.1.ebuild
deleted file mode 100644
index d740098c727d..000000000000
--- a/net-p2p/syncthing/syncthing-1.26.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop go-module systemd xdg-utils
-
-DESCRIPTION="Open Source Continuous File Synchronization"
-HOMEPAGE="https://syncthing.net"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${PN}-source-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unlicense"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 x86"
-IUSE="selinux tools"
-
-RDEPEND="acct-group/syncthing
- acct-user/syncthing
- tools? ( >=acct-user/stdiscosrv-1
- >=acct-user/strelaysrv-1 )
- selinux? ( sec-policy/selinux-syncthing )"
-BDEPEND=">=dev-lang/go-1.20.0"
-
-DOCS=( README.md AUTHORS CONTRIBUTING.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
- "${FILESDIR}"/${PN}-1.18.4-tool_users.patch
- "${FILESDIR}"/${PN}-1.23.2-tests_race.patch
-)
-
-S="${WORKDIR}"/${PN}
-
-src_prepare() {
- # Bug #679280
- xdg_environment_reset
-
- default
- sed -i \
- 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/stdiscosrv|' \
- cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service \
- || die
- sed -i \
- 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
- cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
- || die
-}
-
-src_compile() {
- GOARCH= go run build.go -version "v${PV}" -no-upgrade -build-out=bin/ \
- ${GOARCH:+-goarch="${GOARCH}"} \
- build $(usex tools "all" "") || die "build failed"
-}
-
-src_test() {
- go run build.go test || die "test failed"
-}
-
-src_install() {
- local icon_size
-
- doman man/*.[157]
- einstalldocs
-
- dobin bin/syncthing
-
- domenu etc/linux-desktop/*.desktop
- for icon_size in 32 64 128 256 512; do
- newicon -s ${icon_size} assets/logo-${icon_size}.png ${PN}.png
- done
- newicon -s scalable assets/logo-only.svg ${PN}.svg
-
- if use tools; then
- exeinto /usr/libexec/syncthing
- local exe
- for exe in bin/* ; do
- [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
- done
- fi
-
- systemd_dounit etc/linux-systemd/system/${PN}{@,-resume}.service
- systemd_douserunit etc/linux-systemd/user/${PN}.service
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
-
- keepdir /var/log/${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
-
- if use tools; then
- systemd_dounit cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service
- newconfd "${FILESDIR}"/stdiscosrv.confd stdiscosrv
- newinitd "${FILESDIR}"/stdiscosrv.initd-r1 stdiscosrv
-
- systemd_dounit cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
- newconfd "${FILESDIR}"/strelaysrv.confd strelaysrv
- newinitd "${FILESDIR}"/strelaysrv.initd-r1 strelaysrv
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/stdiscosrv.logrotate strelaysrv
- newins "${FILESDIR}"/strelaysrv.logrotate strelaysrv
- fi
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}