summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-17 06:42:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-17 07:10:22 +0100
commit64982e6f8c5b8acfe4e1dfbe9e06d3912fbc474e (patch)
tree26ad1ae385804352616cf9d1e5cb28fa59f4a0b0
parentdev-python/dnspython: Bump to 2.6.0 (diff)
downloadgentoo-64982e6f8c5b8acfe4e1dfbe9e06d3912fbc474e.tar.gz
gentoo-64982e6f8c5b8acfe4e1dfbe9e06d3912fbc474e.tar.bz2
gentoo-64982e6f8c5b8acfe4e1dfbe9e06d3912fbc474e.zip
dev-python/urwid: Bump to 2.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.6.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 8f2668ca3849..77f347e47f8d 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -6,3 +6,4 @@ DIST urwid-2.5.0.tar.gz 839216 BLAKE2B cd4ca032d725962074cd15494f8d1df0ecb73616c
DIST urwid-2.5.1.tar.gz 840146 BLAKE2B 2fafd5108920064e63dddc40b41dfd88cba1d0f87011d6800e82e83f745e28f1e64fc87389b769b037a6483e22e8baa12b41904f1c9c379f7ae41db2611bc2bb SHA512 d5d5daa9fa2c64c8a63bfeb6bbc14ccd7e8837af6017eab716f3d5a3ce73a9b1c048ff0ffcdb9a193ee6f43b56fa24713e77c22fec76730b8edaad3054ba40e6
DIST urwid-2.5.2.tar.gz 842160 BLAKE2B 72658842360f23104ab3b21fc247d01bbf8ea4b30bb6e665fa8ce4b8661625c9cb62406eb688ad5119beed3e45f7e36fb2b7453db758422bbb95684fac0e2565 SHA512 d4edb37fc5888621453f5b134ac34f8abf8b1155db031268e5a57a73e825c2f7a642743eaa770f0972f3a25bc53439e81cb90742d0d0812ce2ea42fa5ad7ce50
DIST urwid-2.5.3.tar.gz 848047 BLAKE2B 42815e22f2659ee25736767391afbf0189b5bec9d1100ce7631efd037989cfacac7ee921666e2400e1ef7ef114261a948cfac172ac993753ce151b370361d375 SHA512 80c32138347a618fc40e1a26fd174e708a9f8e4e9a8e09edc1d9261a9d73a644e356ce375654a55b5fb8838a820b8ba8b1cc47560c5b44c5c74677399845f578
+DIST urwid-2.6.1.tar.gz 841705 BLAKE2B 8fb74c9f8eebe0ec8dd7b765cfec6525aa7d3f35fa43373e81c7861666f015ad135660d38b1cf413ec1248dce008fefb997e00547ecf014c507334dba33a7e02 SHA512 f2997b239402324ae4d1cefeb2970a0f39f417d477ed930b6f41a36ea1268f3d6be56bbf880bf755e4fa498c53ca659e801db7c525f5a5c279ac486754130e1d
diff --git a/dev-python/urwid/urwid-2.6.1.ebuild b/dev-python/urwid/urwid-2.6.1.ebuild
new file mode 100644
index 000000000000..e13f67f530c0
--- /dev/null
+++ b/dev-python/urwid/urwid-2.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="
+ https://urwid.org/
+ https://pypi.org/project/urwid/
+ https://github.com/urwid/urwid/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf urwid || die
+ eunittest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Trio event loop" "dev-python/trio"
+}