summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:27:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:27:40 +0300
commit649e11a6e64e643ac045ed4a63d9c39dfbca88a2 (patch)
tree7dc2e5c2fe6307cf4c88d2c7351422eae5c82c75
parentdev-cpp/benchmark: Stabilize 1.7.0 arm64, #867988 (diff)
downloadgentoo-649e11a6.tar.gz
gentoo-649e11a6.tar.bz2
gentoo-649e11a6.zip
dev-python/botocore: add 1.27.65
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.65.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 59ee3e019a3f..120d2dd4a596 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.27.56.gh.tar.gz 9545974 BLAKE2B 514c859f854aed83c3bb13ed3eab9999
DIST botocore-1.27.61.gh.tar.gz 9575336 BLAKE2B bbc2bb49ee84293d9d7d9f0cc3da70a141778bd68ecc45117a9e99bd8ceba7576b52ed0d5381b085c6a7ae32195a6709e76144f27681cd8d07338ed404b1b236 SHA512 1e1ce615a2b02bab2587bb475e783d197cf27496cb1c0c1b06c51453e545ed293b1fab555f23a67246a4a5babb6c5d12fafee2d6f8b997d168e43f62a5e16bfd
DIST botocore-1.27.63.gh.tar.gz 9581263 BLAKE2B 3b225160fe0095aa77754c874ceff558c56f547e0454a67fd13c8f093abbef975ff5cf878576b4b6235b1783aaae2278d05026b29d41a95e6168928b035cd1fb SHA512 b3698a0d5ea2e63de3fe94441a1781034d24c0ae5ff06a427ac55eb2cdd05bf917b01fcd9e1bbd389a1d4ac6b625d534b37c1d6c8c72b23670b66d892d5fe6da
DIST botocore-1.27.64.gh.tar.gz 9588817 BLAKE2B 2479d7f6565a78baf7b9504bfdbba74f486b37968bf5074fc1eac150bcf410bd64d23fe47c1a057a38a94c8b4d29bf393613fa739c6c2007e5f523852ae02a24 SHA512 40e689b86997961c149877dc896281f722d09c2ab95149f4a40e98cd55a4a35ce77da5ff793f53801609b9084879ce2af8679771bd6bde2305c9cb27a1360e74
+DIST botocore-1.27.65.gh.tar.gz 9592250 BLAKE2B 7ecb6d13c061100d101b5c3fdf84b25a74137ee49efda86b13549341f6a6932d07ddf0858bd436e0de4719617f2352b423757fd618501ccd1a37b74b9bb5f358 SHA512 cc3ea5329c41e6b0ffc55f170feadc1550e5ca3656c59d809600148cc2268cb2bace6d0b95dfb9031338c90fe3c2e89081bfeb100903c0eed7249612e539c522
diff --git a/dev-python/botocore/botocore-1.27.65.ebuild b/dev-python/botocore/botocore-1.27.65.ebuild
new file mode 100644
index 000000000000..d1a6948e70e5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.65.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}