summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-29 00:34:19 +0100
committerSam James <sam@gentoo.org>2022-09-29 00:34:19 +0100
commit64a4b0d540a446ee02e1b0e85bada75982425eef (patch)
treece52d35d7b17deeb835aeb55ad0a5619ddf06349
parentdev-libs/libmaxminddb: add 1.7.0 (diff)
downloadgentoo-64a4b0d5.tar.gz
gentoo-64a4b0d5.tar.bz2
gentoo-64a4b0d5.zip
app-shells/fzf: add 0.34.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.34.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 79c47f4350e4..c4d8f03a0ca2 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -6,3 +6,5 @@ DIST fzf-0.32.1-deps.tar.xz 16042284 BLAKE2B 9ca05904cfa0790372e1879a77946e337df
DIST fzf-0.32.1.tar.gz 212217 BLAKE2B b1b80bd5ed69dafdca3d52ff1630be99e1384119818bacb31fc04e0cfe58cfd99a4ebb9bd9b8a29e885e7e3db8aa8ba5046107d41a5222c6c05c5d194c42d394 SHA512 8abf7eceec466a3bb0cca48e36a426b4fbf5a4cb07f09756b92705fba11dc432d59102cf0337c8f0bae2782747a45cb7040d2f0de5a2050bb80fd5a6e09f0439
DIST fzf-0.33.0-deps.tar.xz 16062376 BLAKE2B 94d50bf681c7e641ac134978c960b6ceb930ae88119014e2a8b17d7bef115b943c2d89a87a37a4dab446a6d11cc81583900ace31178dfac77d3540d771bfb4f8 SHA512 905eb6ab6ff975824da51261cdf66ee3e69c0be4bef04a2f04ea58433778127c0b3433d12bbba83f220b2d33c00cc5ac313cb05565c644961993b4aac2a1be39
DIST fzf-0.33.0.tar.gz 212698 BLAKE2B ee446b7f451d761abc3b1e6abcae8f9a65232086fe0c0ef479fd898f427ca79f2c125bab2d616965b525b7e355f0b6ea1a65e9ff522230687f1fb119163e5958 SHA512 1359be952b0447da453a772546c1960c01396d37fd84392ad52f6ab9f8793ed282085ffa087cccb176183a923b0f89747d053b7af5b899169083b7a7c7a3ef69
+DIST fzf-0.34.0-deps.tar.xz 16800704 BLAKE2B b518f7bff1ea533af32efcb0e5307580aa921bbc20383bbdb6601c0b2dd50e66a57609c99adb9f71d1d388d08cae22521fea67797036d5dab34c83c45dd719fb SHA512 e5f6db58b43e6e3cb9b38f5fb13ab39b7caa18828516d13b0c4623f11a8553a905d076ef9685abfd9c7b602715d677dae9897359148b5d289b05ad056c60d321
+DIST fzf-0.34.0.tar.gz 214641 BLAKE2B ccb7f57df4305cf07dc8e0ba7384c3a446ddce083727ad98719a327150d853782bf781b0179d02f3f10664ffce501ebab55ccd2d5f61a2e690fa41f1d0f479c1 SHA512 6e2bd9a7c30862c09f627c73504f2a52951476abbd9af64941445862cc9bf783699cc9ccf215e25c49bbb3f9656841581b5805af4658b681b590ca14b5697331
diff --git a/app-shells/fzf/fzf-0.34.0.ebuild b/app-shells/fzf/fzf-0.34.0.ebuild
new file mode 100644
index 000000000000..dfb1e1fbede0
--- /dev/null
+++ b/app-shells/fzf/fzf-0.34.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=04d0b0223fd69984a07a641d0e228c0e9e534825
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}