summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-19 00:02:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-19 00:04:29 +0100
commit64ac9cead26c44d1713167bbe0234308a13ac5d6 (patch)
tree6cdb792a2d6a1ed720bb1705eaf5c1533747b6d2
parentapp-shells/irregular: new package; add 0.7.8 (diff)
downloadgentoo-64ac9cead26c44d1713167bbe0234308a13ac5d6.tar.gz
gentoo-64ac9cead26c44d1713167bbe0234308a13ac5d6.tar.bz2
gentoo-64ac9cead26c44d1713167bbe0234308a13ac5d6.zip
app-shells/ugit: new package; add 0.4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-shells/ugit/Manifest1
-rw-r--r--app-shells/ugit/metadata.xml13
-rw-r--r--app-shells/ugit/ugit-0.4.3.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/app-shells/ugit/Manifest b/app-shells/ugit/Manifest
new file mode 100644
index 000000000000..d42781180b14
--- /dev/null
+++ b/app-shells/ugit/Manifest
@@ -0,0 +1 @@
+DIST ugit-0.4.3.tar.gz 105253 BLAKE2B c1d38fc005a2e577923b57eca1290add3742153155618dff7d88ebe41faeea0a0046da87f89f6bcf675c61e9f5125a840bb690ce6ade4f0f080db4326bb9ec20 SHA512 9ea573029cd3191809a5da60a1533f5f026c1facc9da74a957a166129ba92ba92b4076de2654cc90dfd66563d2858bb25f43d8a3be92404776ce049aed2f6c93
diff --git a/app-shells/ugit/metadata.xml b/app-shells/ugit/metadata.xml
new file mode 100644
index 000000000000..16e9adce3978
--- /dev/null
+++ b/app-shells/ugit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/StartAutomating/ugit/issues/</bugs-to>
+ <remote-id type="github">StartAutomating/ugit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/ugit/ugit-0.4.3.ebuild b/app-shells/ugit/ugit-0.4.3.ebuild
new file mode 100644
index 000000000000..f321df3b91f8
--- /dev/null
+++ b/app-shells/ugit/ugit-0.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell wrapper for git, automate repos and output git as objects"
+HOMEPAGE="https://ugit.start-automating.com/
+ https://github.com/StartAutomating/ugit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/StartAutomating/${PN}.git"
+else
+ SRC_URI="https://github.com/StartAutomating/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/pwsh:*
+"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1"
+ doins *.ps1 *.ps1xml *.psm1
+ doins -r Commands Extensions Types en-us
+
+ dodoc *.md
+}