summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-31 14:20:07 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-31 14:22:36 +0200
commit64be55454886b6b693413b2669a095d35f435e85 (patch)
treee74ef688fe04e1d522f8d8651fd2dda56d3abf5c
parentdev-perl/NetAddr-IP-4.78.0-r0: add alpha keyword (diff)
downloadgentoo-64be55454886b6b693413b2669a095d35f435e85.tar.gz
gentoo-64be55454886b6b693413b2669a095d35f435e85.tar.bz2
gentoo-64be55454886b6b693413b2669a095d35f435e85.zip
app-arch/snappy: Clean up the ebuild, bump to EAPI=6
Replace partial use of deprecated autotools-multilib with correct combination of autotools & multilib-minimal. Clean up the code a bit, and bump it to EAPI=6.
-rw-r--r--app-arch/snappy/snappy-1.1.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/snappy/snappy-1.1.3-r1.ebuild b/app-arch/snappy/snappy-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..2e7e891d2269
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib-minimal
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://github.com/google/snappy"
+SRC_URI="https://github.com/google/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86
+ ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --without-gflags
+ --disable-gtest
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}