summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 19:04:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:14:59 -0600
commit64c1ed5765f9edd240aafe13f8a0704b1e2b0b16 (patch)
tree255c77bb980ef502e9f9970c6a1e2487cb50558b
parentdev-python/oslo-config: bup (diff)
downloadgentoo-64c1ed57.tar.gz
gentoo-64c1ed57.tar.bz2
gentoo-64c1ed57.zip
dev-python/oslo-context: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/oslo-context/Manifest1
-rw-r--r--dev-python/oslo-context/oslo-context-2.12.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/oslo-context/Manifest b/dev-python/oslo-context/Manifest
index 602d460dd815..ea9c6e898f8a 100644
--- a/dev-python/oslo-context/Manifest
+++ b/dev-python/oslo-context/Manifest
@@ -1,2 +1,3 @@
+DIST oslo.context-2.12.1.tar.gz 25879 SHA256 e257c5962928c564ad323a436703733662b39e45d4892d5aff3f290e89e95b94 SHA512 075f402786dfe0e153c0fe21f2a2a8a2099cc2451a6f891fef00e0fd460f9f39220d390c9ae7ba0515a3ad79a94a1b2288c65029aea8f5e7481f8fe181d877b4 WHIRLPOOL 9df270cd41bc2067dcbbba4312fd60682a4f2a5f461d61c80d4b5d5e19a4b1c691c08e8bd34d581e89e4998760f950cc7e8964d04a23c6188cf906892623c55b
DIST oslo.context-2.2.0.tar.gz 16981 SHA256 8c9fbbf56d3f37cf00a039cac3455cffeb6588f61537e36a36ce9447c4be72ec SHA512 f4ccb7a5e652a4820fb40e538a631c11be5f978de2219dc923e18559d30625a31e0ca031f095ce2e0545290cdfdeb714fcf086add6b5a7eb2413ebd1e7a25875 WHIRLPOOL a9a5685dd62105ddaee9c48fdc96231ea700ab8821e7e918920afc1bdf1f1a0e36aa1845c9665bf753fb56d95005f69d4927b12aac9712f41f43e2d89682beaf
DIST oslo.context-2.9.0.tar.gz 23049 SHA256 2682d59ebea3c61421bba98cd3f36dcef5416ad771b220856f14fb528ef81b39 SHA512 6aa062542953007d8cfaf05e231105865c35370a80c9b32a4faae266d07981e83ebe34790b0217d818e2bb40d82d0a7ef3ebf77c7008ce358f7b4e61f6a38ff8 WHIRLPOOL 7ab7cca5c1d5e260e5e97df7cc1a3136e6f96f8237251c3bed46ebc565a9706fcabaa8b138d14e61024d34f34e7be83da313c02e8eba502d68d9b9a1342e1cde
diff --git a/dev-python/oslo-context/oslo-context-2.12.1.ebuild b/dev-python/oslo-context/oslo-context-2.12.1.ebuild
new file mode 100644
index 000000000000..87096c97748d
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.1.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}