summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-02 04:21:27 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-02 04:21:27 +0200
commit64e87607ee03faca4b365625be5dc32c2cbb8cd6 (patch)
tree1c611e39971b4db00f5248efea8c19726a81c965
parentgames-util/antimicrox: new package; add version 3.2.5 (diff)
downloadgentoo-64e87607.tar.gz
gentoo-64e87607.tar.bz2
gentoo-64e87607.zip
dev-lang/dafny-bin: bump to 3.8.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.8.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index f9268f44c180..a10076e98a45 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1,3 +1,4 @@
DIST dafny-3.7.2-x64-ubuntu-16.04.zip 76166815 BLAKE2B a0b2531dedbe413298b6d92a65c854d70785d8732688d1e3556a5e5dc8c268b36dbb994e35960f2a18ecf40e64a6ff0912fa8df79beb6f2f81164be51907d262 SHA512 e472b1c848aece2980e67134a27bc1cab4a531b048790b7b36638e618d59f3f3e8ddcb538cd24723135266899a02b7c8952a73d81c4848e672c21c99c40c5af0
DIST dafny-3.7.3-x64-ubuntu-16.04.zip 76169341 BLAKE2B eb8bee64a0bd39b8af0996e298590c83bcf306dbfda5bc486ef70b13187b4fc0131fd2b98d5eb1b87a3177b1f25c5cd64b82522e4d57cf1b0d2aa1eb34869789 SHA512 0bdda39e8ae22eff72bd57e4ef5f07495e27156b11ff553a2e1f76731d7daa5ce6ac4f4d8b16b3365eacbbd25bc81d88cbfece9a0350e2a0faac2a035f3d5561
DIST dafny-3.8.0-x64-ubuntu-16.04.zip 76181911 BLAKE2B 9fbae78bb08ed448a164188758c53de6eb928f16e941ee2830c5d8ed3980e3f4ccdd4f1b99c30061a5838ef96dd71ad0ac4a69ffdf45ca8a428e37cbd1f8049d SHA512 43628709dfe34d91fda3b723e4f9deacace463a4002c520d62b319f3618b2e62dec93e2fd913926e41c8ef75dd3535a909c4eeb2e58e00faa6ffdd1f028f8277
+DIST dafny-3.8.1-x64-ubuntu-16.04.zip 76192825 BLAKE2B fbfe65f917fb1c04151969e466097ea5703b70fea5c2e04ed6ed756d05c3c46796951d641cca66c30b59d4b70dcee2bef9c7ccac6cd04fe3204b41a08910197c SHA512 ae10f912977827525902317a2215b3066f4271efd2dfdf314859b8c82cfb18ea881bafba5bde0d9f31f3b1429bef252774ca7a495f6661dff7f9f0d5fe042806
diff --git a/dev-lang/dafny-bin/dafny-bin-3.8.1.ebuild b/dev-lang/dafny-bin/dafny-bin-3.8.1.ebuild
new file mode 100644
index 000000000000..39a827f48c53
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Binaries are compiled only for x86_64.
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}