summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-01 19:59:19 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-01 19:59:30 +0200
commit64e8a78f03c04ac19fae6b7c88973440dbb76fad (patch)
treeb7c96b5b10e441bc494afdc4f1623f7b32c7e06a
parentnet-wireless/rtl-sdr: remove duplicate KEYWORDS (diff)
downloadgentoo-64e8a78f.tar.gz
gentoo-64e8a78f.tar.bz2
gentoo-64e8a78f.zip
Revert "net-analyzer/rrdtool: Add live ebuild"
This reverts commit 14c90211f37e2db668d91012866e9ae29d727a3e. Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/rrdtool/rrdtool-9999.ebuild183
1 files changed, 0 insertions, 183 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-9999.ebuild b/net-analyzer/rrdtool/rrdtool-9999.ebuild
deleted file mode 100644
index 966ba5823bc0..000000000000
--- a/net-analyzer/rrdtool/rrdtool-9999.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-DISTUTILS_OPTIONAL=true
-DISTUTILS_SINGLE_IMPL=true
-GENTOO_DEPEND_ON_PERL=no
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit autotools flag-o-matic git-r3 perl-module distutils-r1 multilib
-
-MY_P=${P/_/-}
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
-EGIT_REPO_URI="https://github.com/oetiker/rrdtool-1.x"
-
-LICENSE="GPL-2"
-SLOT="0/8.0.0"
-KEYWORDS=""
-IUSE="dbi doc graph lua perl python rados rrdcgi ruby static-libs tcl tcpd"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-CDEPEND="
- >=dev-libs/glib-2.28.7:2[static-libs(+)?]
- >=dev-libs/libxml2-2.7.8:2[static-libs(+)?]
- dbi? ( dev-db/libdbi[static-libs(+)?] )
- graph? (
- >=media-libs/libpng-1.5.10:0=[static-libs(+)?]
- >=x11-libs/cairo-1.10.2[svg,static-libs(+)?]
- >=x11-libs/pango-1.28
- )
- lua? ( dev-lang/lua:* )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- rados? ( sys-cluster/ceph )
- tcl? ( dev-lang/tcl:0= )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-
-DEPEND="
- ${CDEPEND}
- virtual/pkgconfig
-"
-BDEPEND="
- sys-apps/groff
- virtual/awk
-"
-RDEPEND="
- ${CDEPEND}
-"
-PDEPEND="
- ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.9-disable-rrd_graph-perl.patch
- "${FILESDIR}"/${PN}-1.7.0-disable-rrd_graph-cgi.patch
- "${FILESDIR}"/${PN}-1.7.1-configure.ac.patch
-)
-S=${WORKDIR}/${MY_P}
-
-python_compile() {
- cd bindings/python || die
- distutils-r1_python_compile
-}
-
-python_install() {
- cd bindings/python || die
- distutils-r1_python_install
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # bug 456810
- # no time to sleep
- sed -i \
- -e 's|$LUA_CFLAGS|IGNORE_THIS_BAD_TEST|g' \
- -e 's|^sleep 1$||g' \
- -e '/^dnl.*png/s|^dnl||g' \
- configure.ac || die
-
- # Python bindings are built/installed manually
- sed -i \
- -e '/^all-local:/s| @COMP_PYTHON@||' \
- bindings/Makefile.am || die
-
- if ! use graph; then
- sed -i \
- -e '2s:rpn1::; 2s:rpn2::; 6s:create-with-source-4::;' \
- -e '7s:xport1::; 7s:dcounter1::; 7s:vformatter1::' \
- tests/Makefile.am || die
- fi
-
- eautoreconf
-}
-
-src_configure() {
- export rd_cv_gcc_flag__Werror=no
- export rd_cv_ms_async=ok
-
- filter-flags -ffast-math
-
- export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
-
- # to solve bug #260380
- [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
-
- # Stub configure.ac
- local myconf=()
- if ! use tcpd; then
- myconf+=( "--disable-libwrap" )
- fi
- if ! use dbi; then
- myconf+=( "--disable-libdbi" )
- fi
- if ! use rados; then
- myconf+=( "--disable-librados" )
- fi
-
- econf \
- $(use_enable graph rrd_graph) \
- $(use_enable lua lua-site-install) \
- $(use_enable lua) \
- $(use_enable perl perl-site-install) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable rrdcgi) \
- $(use_enable static-libs static) \
- $(use_enable tcl) \
- $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
- --with-perl-options=INSTALLDIRS=vendor \
- --disable-ruby-site-install \
- --disable-ruby \
- ${myconf[@]}
-}
-
-src_compile() {
- default
-
- use python && distutils-r1_src_compile
-}
-
-src_test() {
- export LC_ALL=C
- default
-}
-
-src_install() {
- default
-
- if ! use doc ; then
- rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
- fi
-
- if use !rrdcgi ; then
- # uses rrdcgi, causes invalid shebang error in Prefix, useless
- # without rrdcgi installed
- rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
- fi
-
- if use perl ; then
- perl_delete_localpod
- perl_delete_packlist
- fi
-
- dodoc CHANGES CONTRIBUTORS NEWS THREADS TODO
-
- find "${ED}"usr -name '*.la' -exec rm -f {} +
-
- keepdir /var/lib/rrdcached/journal/
- keepdir /var/lib/rrdcached/db/
-
- newconfd "${FILESDIR}"/rrdcached.confd rrdcached
- newinitd "${FILESDIR}"/rrdcached.init rrdcached
-
- use python && distutils-r1_src_install
-}