summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 09:20:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 11:58:56 +0100
commit64ebc516b3959d27d3fbe5828e2674e980384121 (patch)
tree0d100318e624c8e53de7535d2786868b618fe1fb
parentdev-python/fsspec: Bump to 2021.11.0 (diff)
downloadgentoo-64ebc516.tar.gz
gentoo-64ebc516.tar.bz2
gentoo-64ebc516.zip
dev-python/botocore: Bump to 1.22.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.22.12.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 731d96448385..25d8dae423af 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,6 +3,7 @@ DIST botocore-1.21.60.tar.gz 8253381 BLAKE2B f035a335f8d72c182f6fbd3f2216608bd56
DIST botocore-1.21.65.tar.gz 8261668 BLAKE2B c955019d06aa1b2f4503673b7d9009e5d6e07ee4348e730e6b4d11285f3030f676f0efda58a72dd92cac8c6ba0cb57f8f879eb5298009ecbd227904d18a453bf SHA512 955d24d2d486524af7bee57a56e2e903458030420198f3e6ab49d61be52b812a98444a9d0f86503b121270d6642345ffad6053ad143374dc56ab908b385afb0a
DIST botocore-1.22.10.tar.gz 8331163 BLAKE2B 51515566ed811cb3698ee3ba9ec15490b8e3198570feadb5bac11164ab9a50a2441d115347e750b1180afad9f535c915445918acc5c83b486992e6040cacd008 SHA512 ac4954da4581755baf6777f71014db005870a8b868020ae1decee9e4eb0d1b9b43f72c2a4cf5e7069933421df7d66313cfb8465978dc516be4de16154c2bff6c
DIST botocore-1.22.11.tar.gz 8340538 BLAKE2B 5db6aebab3ddc3757b495d1babc2916c80098b326b76420a48bf6cf68300809400b90fa2ef4b6701095eb4bf857d940fc4c52c678b9e78d6c7ff7d3c2c0b89af SHA512 4d138b0578b99db5a3945541af994a0ee8f42aeb3a2c0dac72669ef50be5a73f18b82a99109498a66d36f847fe0784518aefad7cdc1e02949a247969105d9109
+DIST botocore-1.22.12.tar.gz 8343683 BLAKE2B df7b2c86f226df14dc8181e8506acc7dd660797311049e2342ec721e853af1158c845749a8143ec6677601420ce6140173da8df5d9e4550cdf9becfc944ebd3c SHA512 0ab78902711960f8373a91af379b4981ab29646cc9f94e49836deaa432695c503879ed0bbbf54e3641e50933b5ed658e48052ca2b8b8391f705284d9abd24c1f
DIST botocore-1.22.5.tar.gz 8301083 BLAKE2B 91f9d38e7c5bcb0b8f58c04547ad45489f58d2240c6b7301cf632969a4a73cf4a1d51c8c68c8def27653c10041d2163ad7ca800dcf6fd07972b506bf2566cae3 SHA512 710a9eeee03dc79ca4ffacc4974f09ca769e1e3b8cb143f6f0349240dd8c2af8ee526a1dadb7310a26019363f683fc4149cb4c73d8b94a856a384fab7f84fb5c
DIST botocore-1.22.6.tar.gz 8302901 BLAKE2B 4627c7bfcbd1750a6517c045b7c7c986c6defb9b35e413fae47e03fe24f3404ff4905c714212ad00193eb4dfa2893a0080da97acb538965a8792278915823a3b SHA512 f39eb6f339011709fa764d3783f225fbd4e4100e51466de9c87d6a3a5430823e81be1b024963ded49785b4fd49febdfa66dd3f91c3b9296508c3d71d794d170d
DIST botocore-1.22.7.tar.gz 8306878 BLAKE2B fd427ced3eb3c2ce71a28f7334ee312293fc98c7b2d91991ce6c894f71bd39b356aa3a2f0a0495fd91e394be4d284b21dc8272863e9568167112aadccaed21a6 SHA512 39eaa5d4bc64669bc398797c69d63157a6a4539bed1c4cdc492c4fe94c9a32d58ac9ea8c06fafd75a5c36ab9d3a5c99f88990b03bcef6cccf7e0c4247330780b
diff --git a/dev-python/botocore/botocore-1.22.12.ebuild b/dev-python/botocore/botocore-1.22.12.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.22.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}