summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-30 11:12:24 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-30 11:14:21 -0400
commit64f21fec630b30508dc28cd6249c9a4fa331ab06 (patch)
tree423442882039c6aa0bb353562af5ac8479476129
parentdev-libs/libwacom: Version bump to 2.2.0 (diff)
downloadgentoo-64f21fec.tar.gz
gentoo-64f21fec.tar.bz2
gentoo-64f21fec.zip
x11-drivers/xf86-input-wacom: Version bump to 1.0.0
package.mask'd for now. Bug: https://bugs.gentoo.org/848501 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--profiles/package.mask1
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild77
3 files changed, 79 insertions, 0 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 474b25296bd0..01d3b8d0aea6 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -37,6 +37,7 @@
# libwacom-2 broke ABI compatibility; reverse dependencies need to be updated.
# Bug #848501
>=dev-libs/libwacom-2.0
+>=x11-drivers/xf86-input-wacom-1.0
# Hans de Graaff <graaff@gentoo.org> (2022-05-29)
# Old slots that are no longer used by dependencies. Upgrade to the
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 69c6988a049b..284d06915322 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1 +1,2 @@
DIST xf86-input-wacom-0.40.0.tar.bz2 629310 BLAKE2B 63b930d3cd786d825250048fdf368fff4e607a39bfabee44e42a2c3ce9693c44ec8966871759d06b823f0568c4e3c2aee003633b863f5437eedc3125f19dd351 SHA512 ce0a24e2e9b4768e7eb65a5c663b3adce856356da7b83a1367dd7e031525805fc26d0b7c8b176a21fcd949c757940e18fec51d7253da157c0ac43ca446c4e536
+DIST xf86-input-wacom-1.0.0.tar.bz2 629019 BLAKE2B 4270dd4988a40d1307d15fce7fa0b6748db754e779cff5473b7a8f8ca5d0bbb36fd6125186e3ddba073f5521ee5c8657523d57dfaa82937a9d50b06605bcb8d1 SHA512 61b48380d8874241bbf687a3916aa089af087e50be93034cfc701a3311513ff855705e3e4073590a1b55be9751ab744166ddf14aa2311fdf0ccc01122af8e315
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild
new file mode 100644
index 000000000000..3805f49a4e28
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libwacom-2:=
+ >=x11-base/xorg-server-1.13:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}