summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-22 07:41:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-22 08:05:27 +0200
commit64f99405f09b9b403f17692f5ec99039e06af6b3 (patch)
tree8fc4303c52b59627a60c279e36c7c73c7180cdcf
parentnet-libs/miniupnpc: Bump to 2.2.4 (diff)
downloadgentoo-64f99405f09b9b403f17692f5ec99039e06af6b3.tar.gz
gentoo-64f99405f09b9b403f17692f5ec99039e06af6b3.tar.bz2
gentoo-64f99405f09b9b403f17692f5ec99039e06af6b3.zip
dev-python/miniupnpc: Bump to 2.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/miniupnpc/Manifest2
-rw-r--r--dev-python/miniupnpc/miniupnpc-2.2.4.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/miniupnpc/Manifest b/dev-python/miniupnpc/Manifest
index 8263aaeaa324..a0c91537c286 100644
--- a/dev-python/miniupnpc/Manifest
+++ b/dev-python/miniupnpc/Manifest
@@ -1,2 +1,4 @@
DIST miniupnpc-2.2.3.tar.gz 101360 BLAKE2B d2a7f64d56be524c5c4aadfecd40da4e1ad040fd7eab64be5b5716cb06047e86e3ed6a9c17f697fd3210af0fb0a6ae032b6ef0a5c1f0d96a2e185db97b0d06e8 SHA512 8b9555d336d5dfe8017a16727f964cddacb3f2bf3528fe3dd2416480da5763b24e1740345e470f2123c170d79d88444e41dbbce4536e6069590925e4805bc5ee
DIST miniupnpc-2.2.3.tar.gz.sig 543 BLAKE2B d10bcb765e0d7a1eb68dc6269080b71535fced443e801a09677872bc498c866a02f22d851db963fb126331f28d2314542507713f514560d9d6eca2262287dc8b SHA512 636ad425b430629ee91b2755b543e9754aa88e243972f47839a2ad958757a12ff598f962e9328e5ad0fa3e0b2f895854c9cb3ca099048e7c132c8ce27806986e
+DIST miniupnpc-2.2.4.tar.gz 102932 BLAKE2B ebfea3fe978280825b7beefb8fe799685a72b0a74c589f5f55c7fde3d8c0d4bbb3d50fa0ff3aed554fa1e24ada0a1ab578328373f0295020415998fe35cde0a0 SHA512 f6515bda86405114016474fef6332c0c09a56b9293cf4391113f549444bab67e7d031af7b94dacff5e7c96d6508527204498c00fb67d6067685ef606b2152595
+DIST miniupnpc-2.2.4.tar.gz.sig 543 BLAKE2B 14a1a1979e2d248bb721c66db3e28c1d6f970477e94235bdfa77763d5f9d4c0da42b23d026e861f48cc34a17e009bf8c57aacc648435ec9e31c3c4b6c3347ffb SHA512 476d1a6cfc519f82461bf4d516f73d40cc3ef27886da68d2e805a24d9c4609c53566e258bd2b622e7716f43c81c14bc0f01b189d23b46b87afc3c76d4e6fa23e
diff --git a/dev-python/miniupnpc/miniupnpc-2.2.4.ebuild b/dev-python/miniupnpc/miniupnpc-2.2.4.ebuild
new file mode 100644
index 000000000000..f2eabd832022
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-2.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 verify-sig
+
+DESCRIPTION="Python bindings for UPnP client library"
+HOMEPAGE="
+ http://miniupnp.free.fr/
+ https://miniupnp.tuxfamily.org/
+ https://github.com/miniupnp/miniupnp/
+"
+SRC_URI="
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz
+ verify-sig? (
+ https://miniupnp.tuxfamily.org/files/${P}.tar.gz.sig
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=net-libs/miniupnpc-${PV}:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ verify-sig? ( sec-keys/openpgp-keys-miniupnp )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
+
+PATCHES=(
+ "${FILESDIR}"/miniupnpc-2.2.3-shared-lib.patch
+)
+
+# DOCS are installed by net-libs/miniupnpc.
+DOCS=()
+
+# Example test command:
+# python -c 'import miniupnpc; u = miniupnpc.UPnP(); u.discover(); u.selectigd(); print(u.externalipaddress())'