summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-29 09:46:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-29 09:48:44 +0100
commit64fae0c2cb02859b1c52ccbf5cc7781815d6771f (patch)
treed03324077674788ac8dfd3ece20aa40bce16117d
parentdev-python/pytest: Remove old (diff)
downloadgentoo-64fae0c2.tar.gz
gentoo-64fae0c2.tar.bz2
gentoo-64fae0c2.zip
dev-python/autopep8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/autopep8/Manifest3
-rw-r--r--dev-python/autopep8/autopep8-1.6.0.ebuild32
-rw-r--r--dev-python/autopep8/autopep8-1.7.0-r1.ebuild39
-rw-r--r--dev-python/autopep8/autopep8-1.7.1.ebuild42
-rw-r--r--dev-python/autopep8/files/autopep8-1.7.0-tomli.patch57
5 files changed, 0 insertions, 173 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 0e0f1d1a64d1..552e26e681d5 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,4 +1 @@
-DIST autopep8-1.6.0.tar.gz 122165 BLAKE2B 606ccf7ab51b52db95287384f9b19fd0f72da9e8fb4537bf395651622a95f88d782679550e61816d60dd3faa2fa096c979575d60cbd95476fa1cd7cf2c4f4180 SHA512 f4ffd564ceb48ff1f37d0a051aa8fefc60595a68709045c13561d8ab73de48dce99cc12acf40559e587ba4f6fddd4727dd2b40691ce43c991d60dda2c8b0d617
-DIST autopep8-1.7.0.tar.gz 117055 BLAKE2B 36e2789551eb671b0bc7481742d9edf25aa622bd3f605fb2491195c45f7630378116e4b0bffb536cf7596b3b1c5ea695796259b944a886d55f05c9891e280d0c SHA512 e93ddf90ff989af71790f70f7e7101f7cc60890c8a976552a097c13b0a0e10c16dfd8770214b19d7fabd59403e6d87a9a37d75a2c6f3ed27f8c82a7d8da95dad
-DIST autopep8-1.7.1.tar.gz 117449 BLAKE2B 27bfdc58f647f3f2a7c3945f7faee152667e1dffc13c2b4a5af1f74e7d544c21d1472dc34c797818ca45fccae9f53e7a333c71b52b825b0fb97b50f12567889b SHA512 7a4a8ebf0bacd781fdf7ae32a34bd64f5b6ba9e8ccef5709799cefe5e5bc24da47f36ea49092e26a7c3e254bbea5d6feaeca38f64ffc3fe440307b1331be4766
DIST autopep8-2.0.0.tar.gz 117507 BLAKE2B 8722b19454f47d0b960e3cc0e18ff3d6150ead009630047ecd1ce9001ea6f6d68595f80d7ad1087bddd2993e95d0634d63495b1d43dee095d114535bf632d1bf SHA512 883b79f7011a374a2ef88073a45748268a20449a3bc8da519c036c71700352dd8c4accc60fcb592f1a53ceac06984fcbe6ede8a272bc718c2b79873be5f35dd8
diff --git a/dev-python/autopep8/autopep8-1.6.0.ebuild b/dev-python/autopep8/autopep8-1.6.0.ebuild
deleted file mode 100644
index ebe36cfed891..000000000000
--- a/dev-python/autopep8/autopep8-1.6.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
-)
diff --git a/dev-python/autopep8/autopep8-1.7.0-r1.ebuild b/dev-python/autopep8/autopep8-1.7.0-r1.ebuild
deleted file mode 100644
index 58d653e49809..000000000000
--- a/dev-python/autopep8/autopep8-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test require in source build
- test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
-)
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
- "${FILESDIR}"/${P}-tomli.patch
-)
diff --git a/dev-python/autopep8/autopep8-1.7.1.ebuild b/dev-python/autopep8/autopep8-1.7.1.ebuild
deleted file mode 100644
index b201d023a72a..000000000000
--- a/dev-python/autopep8/autopep8-1.7.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test require in source build
- test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
-)
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
-)
diff --git a/dev-python/autopep8/files/autopep8-1.7.0-tomli.patch b/dev-python/autopep8/files/autopep8-1.7.0-tomli.patch
deleted file mode 100644
index 6a8dd147d474..000000000000
--- a/dev-python/autopep8/files/autopep8-1.7.0-tomli.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From d0836947df66a052a1d18925a64feb0374598f02 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 6 Apr 2022 18:30:11 +0200
-Subject: [PATCH] Use tomli in place of unmaintained toml package
-
-Use the modern `tomli` TOML parser instead of `toml`. The latter
-package is no longer maintained and does not support TOML 1.0.
----
- autopep8.py | 10 +++++-----
- setup.py | 2 +-
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/autopep8.py b/autopep8.py
-index d856f711..ab1a88ac 100755
---- a/autopep8.py
-+++ b/autopep8.py
-@@ -4040,13 +4040,13 @@ def read_config(args, parser):
-
- def read_pyproject_toml(args, parser):
- """Read pyproject.toml and load configuration."""
-- import toml
-+ import tomli
-
- config = None
-
- if os.path.exists(args.global_config):
-- with open(args.global_config) as fp:
-- config = toml.load(fp)
-+ with open(args.global_config, "rb") as fp:
-+ config = tomli.load(fp)
-
- if not args.ignore_local_config:
- parent = tail = args.files and os.path.abspath(
-@@ -4054,8 +4054,8 @@ def read_pyproject_toml(args, parser):
- while tail:
- pyproject_toml = os.path.join(parent, "pyproject.toml")
- if os.path.exists(pyproject_toml):
-- with open(pyproject_toml) as fp:
-- config = toml.load(fp)
-+ with open(pyproject_toml, "rb") as fp:
-+ config = tomli.load(fp)
- break
- (parent, tail) = os.path.split(parent)
-
-diff --git a/setup.py b/setup.py
-index caa639bf..4849574a 100755
---- a/setup.py
-+++ b/setup.py
-@@ -10,7 +10,7 @@
-
-
- INSTALL_REQUIRES = (
-- ['pycodestyle >= 2.9.1', 'toml']
-+ ['pycodestyle >= 2.9.1', 'tomli']
- )
-
-