summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-06-07 06:32:44 +0800
committerYixun Lan <dlan@gentoo.org>2021-06-07 08:57:51 +0800
commit65035cde3a2de724c85e5da1871a4ae49e96a93b (patch)
treefaad819359611067005a2fc803d67c1b84604af5
parentdev-ml/opam-installer: patch for dose3-6.x compat (diff)
downloadgentoo-65035cde.tar.gz
gentoo-65035cde.tar.bz2
gentoo-65035cde.zip
app-backup/snapper: version bump, 0.9.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/files/snapper-0.9.0-testsuite.patch83
-rw-r--r--app-backup/snapper/snapper-0.9.0.ebuild89
3 files changed, 173 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index 28f2896b3d42..bf2b882ed4ef 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,2 +1,3 @@
DIST snapper-0.8.15.tar.gz 393310 BLAKE2B a977ed8cdcbd73b4e49713dc48407c9bdab88e3084f6d9030c555da860b7277961e8e742103bbe04a05a1efa9bbe916a08fc04da3c2bcb59df8d5e53c038c373 SHA512 cdcc811c4299373e22043780a2cc06e7d5bca44fbf62f92ecb76162e791849b6002b35fe804b8b89524fd5e3ed26ed4120f09b62b202e41fedb7339ab9fe267c
DIST snapper-0.8.16.tar.gz 397215 BLAKE2B b59563746b89916f2906de61d7b7e1bd50be18095fa1ce18bb60e2e7103c5bc11dd1590d776eea2567a2ec39c5c01745afa83a0bc2e2f57142bab1aa68be7638 SHA512 91fb648a32de7c2e9cd549aab2545c75e3bad6a4d52446cb93089469ae6d76ad536f5dcce21b77f633907e9394b44928e99a9003ae6be5508d3fcff0c3fd4aae
+DIST snapper-0.9.0.tar.gz 399600 BLAKE2B 546fcdd8beb4b5404bb718577d53aa284f04a5a5cf1453849158f963604fe34fed0f3f99325449f9805779e845fc6a105008890ed2d2c63d3e0dde33d1d77350 SHA512 0861621764b65365ea7e7cf48baa0c7a64351fed7fca439c91ebf8023dbad6d05c709a5c49b3755d1edbd1b98617b8c202239a63608c11aee808ac21d6a2b412
diff --git a/app-backup/snapper/files/snapper-0.9.0-testsuite.patch b/app-backup/snapper/files/snapper-0.9.0-testsuite.patch
new file mode 100644
index 000000000000..7aa089569b4a
--- /dev/null
+++ b/app-backup/snapper/files/snapper-0.9.0-testsuite.patch
@@ -0,0 +1,83 @@
+diff --git a/configure.ac b/configure.ac
+index 06e4721..c89d0aa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,6 +86,12 @@ AS_IF([test "x$with_conf" != xno], [SYSCONFIG="${with_conf}"])
+
+ CPPFLAGS="${CPPFLAGS} -DCONF_DIR='\"${SYSCONFIG}\"'"
+
++AC_ARG_ENABLE([tests], AC_HELP_STRING([--disable-tests],[Disable internal tests support]),
++ [with_tests=$enableval],[with_tests=yes])
++AM_CONDITIONAL(ENABLE_TESTS, [test "x$with_tests" = "xyes"])
++if test "x$with_tests" = "xyes"; then
++ AC_DEFINE(ENABLE_TESTS, 1, [Enable internal tests support])
++fi
+
+ AC_ARG_ENABLE([btrfs], AC_HELP_STRING([--disable-btrfs],[Disable Btrfs internal snapshots support]),
+ [with_btrfs=$enableval],[with_btrfs=yes])
+diff --git a/testsuite-cmp/Makefile.am b/testsuite-cmp/Makefile.am
+index 81104bf..9c29477 100644
+--- a/testsuite-cmp/Makefile.am
++++ b/testsuite-cmp/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-cmp
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir)
+ AM_LDFLAGS = -lboost_system
+
+@@ -15,3 +16,4 @@ cmp_SOURCES = cmp.cc
+
+ EXTRA_DIST = $(noinst_SCRIPTS)
+
++endif
+diff --git a/testsuite-real/Makefile.am b/testsuite-real/Makefile.am
+index 717313a..527843d 100644
+--- a/testsuite-real/Makefile.am
++++ b/testsuite-real/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite-real
+ #
+
++if ENABLE_TESTS
+ CXXFLAGS += -std=gnu++0x
+
+ AM_CPPFLAGS = -I$(top_srcdir)
+@@ -53,3 +54,4 @@ ug_tests_SOURCES = ug-tests.cc
+
+ EXTRA_DIST = $(test_DATA) $(test_SCRIPTS)
+
++endif
+diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
+index ccb84d3..409e265 100644
+--- a/testsuite/Makefile.am
++++ b/testsuite/Makefile.am
+@@ -2,6 +2,7 @@
+ # Makefile.am for snapper/testsuite
+ #
+
++if ENABLE_TESTS
+ AM_CPPFLAGS = -I$(top_srcdir) $(DBUS_CFLAGS)
+
+ LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lboost_unit_test_framework
+@@ -48,3 +49,4 @@ lvm_utils_test_LDADD = -lboost_unit_test_framework ../snapper/libsnapper.la
+ range_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
+
+ limit_test_LDADD = -lboost_unit_test_framework ../client/utils/libutils.la
++endif
+diff --git a/zypp-plugin/testsuite/Makefile.am b/zypp-plugin/testsuite/Makefile.am
+index 7b52e13..71cb545 100644
+--- a/zypp-plugin/testsuite/Makefile.am
++++ b/zypp-plugin/testsuite/Makefile.am
+@@ -1,3 +1,5 @@
++
++if ENABLE_TESTS
+ if HAVE_ZYPP
+ TEST_LOG_DRIVER = $(SHELL) tap-driver.sh
+
+@@ -12,3 +14,4 @@ TESTS = $(check_SCRIPTS)
+
+ EXTRA_DIST = $(check_SCRIPTS) $(noinst_SCRIPTS) $(noinst_DATA) tap-driver.sh
+ endif
++endif
diff --git a/app-backup/snapper/snapper-0.9.0.ebuild b/app-backup/snapper/snapper-0.9.0.ebuild
new file mode 100644
index 000000000000..3a46790c0d3c
--- /dev/null
+++ b/app-backup/snapper/snapper-0.9.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd bash-completion-r1
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lvm pam test systemd xattr"
+RESTRICT="test"
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-libs/json-c
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+ "${FILESDIR}"/${P}-testsuite.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+ eautoreconf
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --disable-silent-rules
+ --with-conf="/etc/conf.d"
+ --enable-zypp
+ --enable-rollback
+ --enable-btrfs-quota
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable doc)
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable test tests)
+ $(use_enable systemd)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ keepdir /etc/snapper/configs
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+ newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
+}