summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-12 06:34:21 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-12 06:34:21 +0200
commit6503749b2984992f8b87ad91e0523631857cdd34 (patch)
treeb0b38332fcae406d80fec7fc2db66588735584d9
parentdev-ruby/listen: mark ruby21 revision stable (diff)
downloadgentoo-6503749b2984992f8b87ad91e0523631857cdd34.tar.gz
gentoo-6503749b2984992f8b87ad91e0523631857cdd34.tar.bz2
gentoo-6503749b2984992f8b87ad91e0523631857cdd34.zip
dev-ruby/listen: cleanup
Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/listen/listen-0.7.3-r1.ebuild34
-rw-r--r--dev-ruby/listen/listen-1.3.1-r2.ebuild36
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-ruby/listen/listen-0.7.3-r1.ebuild b/dev-ruby/listen/listen-0.7.3-r1.ebuild
deleted file mode 100644
index 985f8e2c1d9d..000000000000
--- a/dev-ruby/listen/listen-0.7.3-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Listens to file modifications and notifies you about the changes"
-HOMEPAGE="https://github.com/guard/listen"
-SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x64-macos"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
-
-all_ruby_prepare() {
- # Avoid a spec with incorrect stubbing.
- sed -i -e '/loads all the registerd dependencies/,/ end/ s:^:#:' \
- -e '/return true when dependencies are loaded/,/ end/ s:^:#:' \
- spec/listen/dependency_manager_spec.rb || die
-}
diff --git a/dev-ruby/listen/listen-1.3.1-r2.ebuild b/dev-ruby/listen/listen-1.3.1-r2.ebuild
deleted file mode 100644
index f9c549ee67cc..000000000000
--- a/dev-ruby/listen/listen-1.3.1-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Listens to file modifications and notifies you about the changes"
-HOMEPAGE="https://github.com/guard/listen"
-SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x64-macos"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
-
-all_ruby_prepare() {
- sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
- # Drop failing test
- sed -i -e '/#85/,+17d' spec/listen/directory_record_spec.rb || die
-
- # Drop dependencies for file system events not available on Gentoo.
- sed -i -e '/\(fsevent\|kqueue\)/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}