summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:53 +0100
commit650ba2b986796e954ad91afd5703143631ae280e (patch)
treea2308bc8a528e489c7185ece64bdda2b442bae43
parentdev-python/jupyter_kernel_test: Remove old (diff)
downloadgentoo-650ba2b986796e954ad91afd5703143631ae280e.tar.gz
gentoo-650ba2b986796e954ad91afd5703143631ae280e.tar.bz2
gentoo-650ba2b986796e954ad91afd5703143631ae280e.zip
dev-python/jupyterlab-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index 4a919968f631..37f7508e1ff9 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1,2 +1 @@
-DIST jupyterlab_server-2.19.0.tar.gz 69979 BLAKE2B f44eea3aa2a19c0f2e548b33e1677a8daf4b6098bfb682f3ebae816d38c6cd24769aea35053f2a9e656e5b2bba2a032d4bd75ba976d30238fa4d27c9a1a69867 SHA512 058a1663ca1d6663be9de1243b178637a61e2ff156ca00163d9f30301d8527ca26235f1d3183bc2b48b6b4b82dbea595a4c7f0a989736b603851f5d78f8da078
DIST jupyterlab_server-2.20.0.tar.gz 70481 BLAKE2B 188b8a9bd2bfc5a27ce6f8488d7768484fd71ae8bb93f28c8a49f63b1aef13551c55d7e18531830df26617883f6b780a491d3522a0dcb3ecddcc433cfb35f97b SHA512 7d9a86f56686344ffc1ad11a9fc7c736a2ac0e6b8c31f8b6d8e35e5fd982454b2362073038dfc2ed3a4f03ef53e2afcaa33fc2c956b63e44c3d1ae6efa1f9251
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild
deleted file mode 100644
index 89d3aefe8a12..000000000000
--- a/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=hatchling
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyterlab/jupyterlab_server/
- https://pypi.org/project/jupyterlab-server/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
- >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.28[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
- <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_server[${PYTHON_USEDEP}]
- >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
- dev-python/pytest_jupyter[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# TODO: package autodoc_traits
-#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
-
-python_test() {
- local EPYTEST_IGNORE=(
- tests/test_translation_api.py
- )
-
- EPYTEST_DESELECT=(
- # Fails if terminal not available
- tests/test_labapp.py::test_page_config
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_tornasync.plugin
-}