summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-04-07 18:26:56 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-04-07 21:58:49 -0700
commit6517a9c66a1b7e8bfc9ba4b2a9636ff2b052758b (patch)
tree0ed01be53844ae0ab90d1d87b9c2b7524a837135
parentdev-lang/rust: add 1.60.0 (diff)
downloadgentoo-6517a9c66a1b7e8bfc9ba4b2a9636ff2b052758b.tar.gz
gentoo-6517a9c66a1b7e8bfc9ba4b2a9636ff2b052758b.tar.bz2
gentoo-6517a9c66a1b7e8bfc9ba4b2a9636ff2b052758b.zip
virtual/rust: add 1.60.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--virtual/rust/rust-1.60.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.60.0.ebuild b/virtual/rust/rust-1.60.0.ebuild
new file mode 100644
index 000000000000..8de903f38293
--- /dev/null
+++ b/virtual/rust/rust-1.60.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"