summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 13:23:21 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 13:23:21 -0800
commit6522f8504718aeedb0f8a2ea60717bd0d80a3d3e (patch)
tree778dac697656fc7162e224ba72f06f69512f8c07
parentnet-misc/gerbera: Version bump (diff)
downloadgentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.tar.gz
gentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.tar.bz2
gentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.zip
dev-python/twine: Version bump to 1.15.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/files/twine-1.15.0-tests.patch21
-rw-r--r--dev-python/twine/twine-1.15.0.ebuild51
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 4a2188bc17f1..56ff54b86cd6 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,2 +1,3 @@
DIST twine-1.11.0.tar.gz 55301 BLAKE2B 88e88bc88a6dc8320064b3e296d85f1614d1ecf1628c8442737566ac58c3296b2292f147c0b39047a1d13a3ac98297fd7a77a0ba6fdb6ff04e59d16bc8ed463a SHA512 28e588f26b59bc9f4a8481caf2353934ad6927734762ffebb4416c147ec9e6dffb37092def20a76eb888c94b27f97e013dacc42c63e5dcda30f4290bb6c90a22
+DIST twine-1.15.0.tar.gz 135851 BLAKE2B 5e85c30e23615e9fa7e40ed767412560b29c42ec777afbb17850781a384bc2d3787534a8114a65ac2374ab80441eb2d3b6d75dcff400e7b47a42453a9210130d SHA512 e0eae05c108e1e766a0a8ec684e3423b0537c8aa671675f30403171fd4f48ec65666d407df53f6dd9eefa0b98e5fd2fdf7dbf1f0f9150686c499de131f6f2435
DIST twine-3.0.0.tar.gz 138502 BLAKE2B 80cc475704979030435505103e45cfd051d2e3979e6fd9d4ad33fdbb2644bdebf789c504491f22a161f346295222287114ab68034560360f08a1beadefb20ac0 SHA512 1f5577c74c47618ae07672b53633110a5ecb486d25046cb87f36cbf5974b679714f962803b9dc6e970c57d8f2542b323e11437e76effe7172511557b56df5f12
diff --git a/dev-python/twine/files/twine-1.15.0-tests.patch b/dev-python/twine/files/twine-1.15.0-tests.patch
new file mode 100644
index 000000000000..ce75469c091f
--- /dev/null
+++ b/dev-python/twine/files/twine-1.15.0-tests.patch
@@ -0,0 +1,21 @@
+diff --git a/tests/test_package.py b/tests/test_package.py
+index 8e4fbbb..35c9c52 100644
+--- a/tests/test_package.py
++++ b/tests/test_package.py
+@@ -214,11 +214,11 @@ TWINE_1_5_0_WHEEL_HEXDIGEST = package.Hexdigest(
+ 'b657a4148d05bd0098c1d6d8cc4e14e766dbe93c3a5ab6723b969da27a87bac0',
+ )
+
+-if platform.python_implementation().lower() == 'pypy':
+- # pyblake2 refuses to install on PyPy
+- TWINE_1_5_0_WHEEL_HEXDIGEST = TWINE_1_5_0_WHEEL_HEXDIGEST._replace(
+- blake2=None,
+- )
++#if platform.python_implementation().lower() == 'pypy':
++# # pyblake2 refuses to install on PyPy
++# TWINE_1_5_0_WHEEL_HEXDIGEST = TWINE_1_5_0_WHEEL_HEXDIGEST._replace(
++# blake2=None,
++# )
+
+
+ def test_hash_manager():
diff --git a/dev-python/twine/twine-1.15.0.ebuild b/dev-python/twine/twine-1.15.0.ebuild
new file mode 100644
index 000000000000..c4de1ffe7f13
--- /dev/null
+++ b/dev-python/twine/twine-1.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5})
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/twine-1.15.0-tests.patch"
+)
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}