summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-10 01:35:08 +0000
committerSam James <sam@gentoo.org>2024-03-10 01:36:48 +0000
commit653c4587d6f9c877e538b17e7f64951c402a8826 (patch)
tree597f783846e9141dfabd30c0f9945f2d30db55a7
parentapp-misc/elasticsearch: drop 8.11.3 (diff)
downloadgentoo-653c4587.tar.gz
gentoo-653c4587.tar.bz2
gentoo-653c4587.zip
net-misc/suite3270: add 4.3_p6
Switch from USE=X -> USE=gui per QA policy. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/suite3270/Manifest1
-rw-r--r--net-misc/suite3270/suite3270-4.3_p6.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/net-misc/suite3270/Manifest b/net-misc/suite3270/Manifest
index 8a15696fb58f..86e4db3ae2ad 100644
--- a/net-misc/suite3270/Manifest
+++ b/net-misc/suite3270/Manifest
@@ -1,2 +1,3 @@
DIST suite3270-4.0ga13-src.tgz 3317494 BLAKE2B 898f279143006e1fc1f470bda3917afe85957de745676dc915f9c94292824ba0e10fc2ccf0a47e307c41e48741a3da7c066c45f63c917295e0522122226b79dd SHA512 bdf9c5d129419c87b45907186e5f158d8623009151357e4d8a3d08ffff2f3729449cead84d005227bfb32968ae363d1a29350692cabe9bf8b71f760eda3f496b
DIST suite3270-4.2ga5-src.tgz 4192998 BLAKE2B 2e29a9e9f25688bd5fc84101cab684c0fcdde9eff5e65cf0f247e9942990c812174eec17569716928de299fec0d87e77c785d8415370f7245cc0909c7e2020dd SHA512 4a5847c81262a099c68a914141bc7eba7b7b46f0ed4dabc1e7421b4244ea1ca5877e472262f9a4ab2f1a9ca72bde3901f8281dc0957046d3355ed98377de0492
+DIST suite3270-4.3ga6-src.tgz 13188235 BLAKE2B 2ca334b82cc42818ac9d0733a8d93f3b73e598f9de94e7166972d88079cfcf98877eb08587ac24e096f9b6457c96344abd37c4bb9d7af4f7e50c3ef191f82714 SHA512 5250d382185acb7f89cb2a6ff5050aa05be809e7bd2bbe25cf74bd3177ebba8ea24d990b3f20e308a5cffa8bdbd5d1c82ba956db76a2812b5ae42ea57602d2bd
diff --git a/net-misc/suite3270/suite3270-4.3_p6.ebuild b/net-misc/suite3270/suite3270-4.3_p6.ebuild
new file mode 100644
index 000000000000..99b045b00d0b
--- /dev/null
+++ b/net-misc/suite3270/suite3270-4.3_p6.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=${PV/_p/ga}
+MY_P=${PN}-${MY_PV}
+SUB_PV=${PV:0:3}
+S="${WORKDIR}"/${PN}-${SUB_PV}
+
+# Only the x3270 package installs fonts
+FONT_PN="x3270"
+FONT_S="${S}"/${FONT_PN}
+
+inherit autotools font
+
+DESCRIPTION="Complete 3270 (S390) access package"
+HOMEPAGE="http://x3270.bgp.nu/"
+SRC_URI="mirror://sourceforge/x3270/${MY_P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE="cjk doc gui ncurses ssl tcl"
+
+RDEPEND="
+ gui? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+ ssl? ( dev-libs/openssl:= )
+ ncurses? (
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ )
+ tcl? ( dev-lang/tcl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ gui? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ gui? (
+ x11-apps/bdftopcf
+ >=x11-apps/mkfontscale-1.2.0
+ x11-misc/xbitmaps
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1-musl-wint-t-fix.patch
+ "${FILESDIR}"/${PN}-4.2_p5-ncurses-pkg-config.patch
+)
+
+src_prepare() {
+ default
+
+ # Some subdirs (like c3270/x3270/s3270) install the same set of data files
+ # (they have the same contents). Wrap that in a retry to avoid errors.
+ cat <<-EOF > _install || die
+ #!/bin/sh
+ for n in 1 2 3 4 5; do
+ install "\$@" && exit
+ echo "retrying ..."
+ done
+ exit 1
+ EOF
+ chmod a+rx _install || die
+ # Can't use the ${INSTALL} var as top level configure also uses it.
+ # https://sourceforge.net/p/x3270/bugs/15/
+ export ac_cv_path_install="${S}"/_install
+
+ AT_NOEAUTOHEADER=yes eautoreconf
+}
+
+src_configure() {
+ econf \
+ --cache-file="${S}"/config.cache \
+ --enable-s3270 \
+ --enable-pr3287 \
+ $(use_enable ncurses c3270) \
+ $(use_enable tcl tcl3270) \
+ $(use_enable gui x3270) \
+ $(use_with gui x) \
+ $(use_with gui fontdir "${FONTDIR}")
+}
+
+src_install() {
+ use gui && dodir "${FONTDIR}"
+
+ emake DESTDIR="${D}" install{,.man}
+
+ use gui && font_src_install
+}
+
+pkg_postinst() {
+ use gui && font_pkg_postinst
+}
+
+pkg_postrm() {
+ use gui && font_pkg_postrm
+}