summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 09:58:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:26 +0200
commit655e22d852f7864da784eaade86a31d069e7b9f2 (patch)
tree49b72f59edea96ac453811489cd8236f474660a4
parentapp-office/calligraplan: Fix missing header with Frameworks 5.61 (diff)
downloadgentoo-655e22d8.tar.gz
gentoo-655e22d8.tar.bz2
gentoo-655e22d8.zip
kde-apps/kpat: Fix missing header with Frameworks 5.61
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kpat/files/kpat-19.04.3-missing-header.patch42
-rw-r--r--kde-apps/kpat/kpat-19.04.3.ebuild2
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/kpat/files/kpat-19.04.3-missing-header.patch b/kde-apps/kpat/files/kpat-19.04.3-missing-header.patch
new file mode 100644
index 000000000000..be272b75f4ca
--- /dev/null
+++ b/kde-apps/kpat/files/kpat-19.04.3-missing-header.patch
@@ -0,0 +1,42 @@
+From 5b68765dcd431bca55582c4996adf73ed0ac0123 Mon Sep 17 00:00:00 2001
+From: Luca Beltrame <lbeltrame@kde.org>
+Date: Thu, 18 Jul 2019 23:28:57 +0200
+Subject: Add QMap include to fix build (with Qt 5.13)
+
+It looks it's no longer included transitively.
+---
+ mainwindow.h | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/mainwindow.h b/mainwindow.h
+index 0d6b2da..ca6ee0f 100644
+--- a/mainwindow.h
++++ b/mainwindow.h
+@@ -23,7 +23,7 @@
+ * -------------------------------------------------------------------------
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+- * published by the Free Software Foundation; either version 2 of
++ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+@@ -53,6 +53,7 @@ class KRecentFilesAction;
+ class KToggleAction;
+ class QUrl;
+ #include <KXmlGuiWindow>
++#include <QMap>
+
+ class QLabel;
+
+@@ -127,7 +128,7 @@ private:
+ QAction * m_upAction;
+ QAction * m_downAction;
+ QAction * m_cancelAction;
+- QAction * m_pickUpSetDownAction;
++ QAction * m_pickUpSetDownAction;
+
+ KRecentFilesAction * m_recentFilesAction;
+ QAction * m_saveAction;
+--
+cgit v1.1
diff --git a/kde-apps/kpat/kpat-19.04.3.ebuild b/kde-apps/kpat/kpat-19.04.3.ebuild
index 74d19ed5d4bb..fbe9f755a2f3 100644
--- a/kde-apps/kpat/kpat-19.04.3.ebuild
+++ b/kde-apps/kpat/kpat-19.04.3.ebuild
@@ -32,3 +32,5 @@ DEPEND="
dev-games/freecell-solver
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-missing-header.patch )