summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-01-01 17:45:25 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-01-01 17:46:17 +0100
commit6564cb724ea72dd9d0a10bd7b5e2f1c9cd8fc5bd (patch)
tree30b0f656d95dac7974572f1fbcd2f8533e8acb11
parentapp-misc/broot: add 1.31.0 (diff)
downloadgentoo-6564cb724ea72dd9d0a10bd7b5e2f1c9cd8fc5bd.tar.gz
gentoo-6564cb724ea72dd9d0a10bd7b5e2f1c9cd8fc5bd.tar.bz2
gentoo-6564cb724ea72dd9d0a10bd7b5e2f1c9cd8fc5bd.zip
sci-libs/branca: add USE=doc, remove old, PythonCompatUpdate
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.6.0-r1.ebuild30
-rw-r--r--sci-libs/branca/branca-0.7.0-r1.ebuild (renamed from sci-libs/branca/branca-0.7.0.ebuild)6
3 files changed, 4 insertions, 33 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index dbab1b6bbd41..873af0be1023 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1,2 +1 @@
-DIST branca-0.6.0.tar.gz 40167 BLAKE2B 23cbe442862e9575d84dfb5bb1760acf2a1301be0f68bedc9965d9d3a8be090755f78640ed919b5ba8521ab30e8c52c69ea87ff2772d9fd6b3e338680b5219bb SHA512 e80b3d173bc487857ab42d10365540e91cb6fc5def61bb76f418e2da8e74c9bf69e0ca46f86a47f96f5db48d0e98d6ad3091107dd1a5ca479c52adbfa3a79a9c
DIST branca-0.7.0.tar.gz 42990 BLAKE2B b8de083b0b94d35dbb6df5d230e388832fe027d756767d24ae8091f25d9846ac1f2ae72799aa83583c99ec02d955c7f8cb80183f1543e503d0a802ce051acac5 SHA512 bfe6afd93752dda57e55ba7bdd433e079b51798056b2be8d9c19d4ccc4ed94cc95b733cabf0981c908887c1f8a96e16bd11cb1b495243ac91df4c1c1c1253282
diff --git a/sci-libs/branca/branca-0.6.0-r1.ebuild b/sci-libs/branca/branca-0.6.0-r1.ebuild
deleted file mode 100644
index 7403664fb4dc..000000000000
--- a/sci-libs/branca/branca-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-inherit distutils-r1
-
-DESCRIPTION="spinoff from folium, host the non-map-specific features"
-HOMEPAGE="https://github.com/python-visualization/branca"
-SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
-
-RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/selenium[${PYTHON_USEDEP}] )"
-BDEPEND="dev-python/setuptools-scm"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -m 'not headless'
-}
diff --git a/sci-libs/branca/branca-0.7.0.ebuild b/sci-libs/branca/branca-0.7.0-r1.ebuild
index 7b3846dbca34..dcdfcadc60a8 100644
--- a/sci-libs/branca/branca-0.7.0.ebuild
+++ b/sci-libs/branca/branca-0.7.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
inherit distutils-r1
@@ -25,6 +25,8 @@ BDEPEND="dev-python/setuptools-scm"
distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
python_test() {
epytest -m 'not headless'
}