summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-26 08:25:08 +0000
committerSam James <sam@gentoo.org>2021-11-26 08:25:08 +0000
commit65679c86bec8982d7a95220891d2438ffc63a192 (patch)
treef1979419ec48433c4d8c8ddadb75ddc38c60d255
parentdev-python/cryptography: fix MisplacedEclassVar (diff)
downloadgentoo-65679c86.tar.gz
gentoo-65679c86.tar.bz2
gentoo-65679c86.zip
dev-python/cryptography: fix DEPEND for 36.0.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/cryptography/cryptography-36.0.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/cryptography/cryptography-36.0.0.ebuild b/dev-python/cryptography/cryptography-36.0.0.ebuild
index 67cf4915f191..1d19af956958 100644
--- a/dev-python/cryptography/cryptography-36.0.0.ebuild
+++ b/dev-python/cryptography/cryptography-36.0.0.ebuild
@@ -73,15 +73,12 @@ SLOT="0"
# See bug #769482, bug #827350
#KEYWORDS="~amd64 ~ppc64"
-RDEPEND="
- >=dev-libs/openssl-1.0.2o-r6:0=
+RDEPEND=">=dev-libs/openssl-1.0.2o-r6:0="
+DEPEND="${RDEPEND}
$(python_gen_cond_dep '
>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
- ' 'python*')
-"
-BDEPEND="
- ${DEPEND}
- dev-python/setuptools_rust[${PYTHON_USEDEP}]
+ ' 'python*')"
+BDEPEND="dev-python/setuptools_rust[${PYTHON_USEDEP}]
test? (
>=dev-python/hypothesis-1.11.4[${PYTHON_USEDEP}]
dev-python/iso8601[${PYTHON_USEDEP}]
@@ -90,8 +87,7 @@ BDEPEND="
dev-python/pytest-subtests[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- )
-"
+ )"
# Files built without CFLAGS/LDFLAGS, acceptable for rust
QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/cryptography/hazmat/bindings/_rust.abi3.so"