summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-02 22:14:14 -0500
committerSam James <sam@gentoo.org>2024-03-03 04:00:11 +0000
commit656a69372c6b737ed1f5fcb37dcbc97f5fff27ef (patch)
tree93aa82dae74d0c22ef01d1a6cf0900022244508e
parentsys-libs/pam_wrapper: disable py3.9 (diff)
downloadgentoo-656a69372c6b737ed1f5fcb37dcbc97f5fff27ef.tar.gz
gentoo-656a69372c6b737ed1f5fcb37dcbc97f5fff27ef.tar.bz2
gentoo-656a69372c6b737ed1f5fcb37dcbc97f5fff27ef.zip
x11-libs/xapp: fix broken, untested sed
This is why sed is bad. The sed didn't apply, even in the first edition of the ebuild that it was introduced in, because it used incorrect sed syntax. Because it was a sed, this fact escaped all notice even though it never ever worked. Just use a patch. Patches always either apply or fail, they aren't prone to silently doing *nothing*. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-libs/xapp/files/0001-don-t-install-pastebin-upload-wrapper.patch26
-rw-r--r--x11-libs/xapp/xapp-2.8.2-r1.ebuild (renamed from x11-libs/xapp/xapp-2.8.2.ebuild)6
2 files changed, 29 insertions, 3 deletions
diff --git a/x11-libs/xapp/files/0001-don-t-install-pastebin-upload-wrapper.patch b/x11-libs/xapp/files/0001-don-t-install-pastebin-upload-wrapper.patch
new file mode 100644
index 000000000000..1609c909f4bd
--- /dev/null
+++ b/x11-libs/xapp/files/0001-don-t-install-pastebin-upload-wrapper.patch
@@ -0,0 +1,26 @@
+From 3ef6f2cb9da305ac71d807ac3a51c3c8c345676f Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Sat, 2 Mar 2024 22:12:44 -0500
+Subject: [PATCH] don't install pastebin upload wrapper
+
+Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
+---
+ scripts/meson.build | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/scripts/meson.build b/scripts/meson.build
+index 7b1c1bc..6c31e5d 100644
+--- a/scripts/meson.build
++++ b/scripts/meson.build
+@@ -1,7 +1,4 @@
+-scripts = files(
+- 'pastebin',
+- 'upload-system-info',
+- 'xapp-gpu-offload')
++scripts = files('xapp-gpu-offload')
+
+ if get_option('xfce')
+ scripts += files('xfce4-set-wallpaper')
+--
+2.43.0
+
diff --git a/x11-libs/xapp/xapp-2.8.2.ebuild b/x11-libs/xapp/xapp-2.8.2-r1.ebuild
index 624f77b5c144..e98da20b7e9c 100644
--- a/x11-libs/xapp/xapp-2.8.2.ebuild
+++ b/x11-libs/xapp/xapp-2.8.2-r1.ebuild
@@ -53,15 +53,15 @@ PATCHES=(
# Make desktop environment integrations optional
# https://github.com/linuxmint/xapp/pull/176
"${FILESDIR}"/${PN}-optional-de-options.patch
+
+ # don't install pastebin upload wrapper
+ "${FILESDIR}"/0001-don-t-install-pastebin-upload-wrapper.patch
)
src_prepare() {
vala_src_prepare
default
- # don't install pastebin upload wrapper
- sed -iE "s/'(pastebin|upload-system-info)',//" scripts/meson.build || die
-
# Fix meson helpers
python_setup
python_fix_shebang .