summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-03 08:43:21 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-03 08:48:04 +0100
commit657111f61f23a3a64c09d850a5cd4a0bd9c084d2 (patch)
treee909b415fd91e00b0941e63cccf9c29140c02ba0
parentdev-ruby/brotli: add 0.5.0 (diff)
downloadgentoo-657111f6.tar.gz
gentoo-657111f6.tar.bz2
gentoo-657111f6.zip
dev-ruby/localhost: add 1.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/localhost/Manifest1
-rw-r--r--dev-ruby/localhost/localhost-1.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
index 3522459d9953..02a95e02be64 100644
--- a/dev-ruby/localhost/Manifest
+++ b/dev-ruby/localhost/Manifest
@@ -1 +1,2 @@
DIST localhost-1.1.10.tar.gz 2128142 BLAKE2B 06e4ab07bc273b8beba5fb3ee3f64e171a6c4a2e944c6d5e432417560283230277213732bf23ddd12e9737b2803582a11fdaa76356d14d2bdbd4e90d402c6204 SHA512 946ef247b256165cf5c849a32c0ba8dd2007164bd1549a20aca595328174709e9213ba8a98448dc41a57558b00147c3b7428b7bc625059ab24f89c94ff8850e9
+DIST localhost-1.2.0.tar.gz 2128359 BLAKE2B 793e43779ec0b1392104914d9adc1d468820f54b920a8ec4e4f538b313e607a6016a0d2d7b8db242571bdd561161bd71ef781eae310d1f57005c2b0a0fa5c5b4 SHA512 f60cf31a31ac43962e98e933955973ce4bdf76252e43ee3ef969fe104fb71bc5d2faa3213c93532acba28650cd453663785c15b33eed65309f8c235ce116b70d
diff --git a/dev-ruby/localhost/localhost-1.2.0.ebuild b/dev-ruby/localhost/localhost-1.2.0.ebuild
new file mode 100644
index 000000000000..3d7b9f9412c2
--- /dev/null
+++ b/dev-ruby/localhost/localhost-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manage a local CA for self-signed localhost development servers"
+HOMEPAGE="https://github.com/socketry/localhost"
+SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/async-io
+ dev-ruby/async-process
+ dev-ruby/sus-fixtures-async
+ )
+"
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/covered/Id' config/sus.rb || die
+}
+
+each_ruby_test() {
+ # Tests fail in parallel as it tries to use the same port so
+ # manually replicate ruby-ng_sus for now, as ruby-ng_sus runs sus-parallel.
+ ${RUBY} -S sus || die
+}