summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-21 18:30:30 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-21 18:40:13 -0400
commit65874513a2b51ba7bf7ba0b053ba6b2f8732e458 (patch)
tree5719213c8a506003ff85a20f584533f434a0a1e3
parentmedia-libs/libepoxy: Add Python 3.12 compatibility (diff)
downloadgentoo-65874513a2b51ba7bf7ba0b053ba6b2f8732e458.tar.gz
gentoo-65874513a2b51ba7bf7ba0b053ba6b2f8732e458.tar.bz2
gentoo-65874513a2b51ba7bf7ba0b053ba6b2f8732e458.zip
media-libs/libepoxy: RDEPEND on libglvnd[X?]
And remove IUSE=+egl at the same time since libglvnd always provides libEGL. Bug: https://bugs.gentoo.org/929993 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/libepoxy/libepoxy-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-libs/libepoxy/libepoxy-9999.ebuild b/media-libs/libepoxy/libepoxy-9999.ebuild
index 5bc5cc5fd964..5e82b138f474 100644
--- a/media-libs/libepoxy/libepoxy-9999.ebuild
+++ b/media-libs/libepoxy/libepoxy-9999.ebuild
@@ -20,12 +20,13 @@ HOMEPAGE="https://github.com/anholt/libepoxy"
LICENSE="MIT"
SLOT="0"
-IUSE="+egl test +X"
+IUSE="test +X"
RESTRICT="!test? ( test )"
RDEPEND="
- egl? ( media-libs/mesa[egl(+),${MULTILIB_USEDEP}] )"
+ media-libs/libglvnd[X?,${MULTILIB_USEDEP}]
+"
DEPEND="${RDEPEND}
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
BDEPEND="${PYTHON_DEPS}
@@ -35,7 +36,7 @@ PATCHES=( "${FILESDIR}"/libepoxy-1.5.10-use-opengl.pc-without-x.patch )
multilib_src_configure() {
local emesonargs=(
- -Degl=$(usex egl)
+ -Degl=yes
-Dglx=$(usex X)
$(meson_use X x11)
$(meson_use test tests)