summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-10 16:42:49 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-10 16:43:30 +0100
commit65a82d095f47302279d88c1ac7816ba41a865a45 (patch)
tree87e0c3c811ffb2803c3767320ed2ceecb66299ca
parentnet-wireless/bluez-tools: Fix compilation with gcc-10 (diff)
downloadgentoo-65a82d095f47302279d88c1ac7816ba41a865a45.tar.gz
gentoo-65a82d095f47302279d88c1ac7816ba41a865a45.tar.bz2
gentoo-65a82d095f47302279d88c1ac7816ba41a865a45.zip
sys-auth/rtkit: bump to 0.13
Now with meson and no patches! Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-auth/rtkit/Manifest1
-rw-r--r--sys-auth/rtkit/rtkit-0.13.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-auth/rtkit/Manifest b/sys-auth/rtkit/Manifest
index c99b05393585..6f7fdc043c68 100644
--- a/sys-auth/rtkit/Manifest
+++ b/sys-auth/rtkit/Manifest
@@ -1,2 +1,3 @@
DIST rtkit-0.11.tar.xz 126748 BLAKE2B e989f1fb9e33c2e06d7eedbe0aab45982d458b6a80aa8ba9b05ae94ed048ef1351d30f8800859a08d8bb0a53891e7b63f6bda6308b4521da10a61182ca3921f9 SHA512 4641af965dc64c0f498ae469fbee1ceb337204fa7d778fbbb41f2b5c5e88947e633c7e9ad037274fdd778c3c097a4a1dbb0b2add287d74eccbcd2d357cb2da22
DIST rtkit-0.12.tar.xz 127504 BLAKE2B c2132098b98f24c1f1662df08c9940772cdad9a326c0c4b9180aac2e0878b0c71e5917ab2535628aab12ff29546faef1c68f455625c77bc2bac25864dddfa4b6 SHA512 cee48058367b5b8a705203865538d0ab4bda9d2f1d06d155360922cb095b5d6a5b0311fdda6c45d9f33227324394ca5fd3b5a399fc71e11ea4c609eab18a7b04
+DIST rtkit-0.13.tar.xz 130796 BLAKE2B 842d04556a47c199bed9fc6bc9281c0d88f83e183f01ef57ecbd80ce72949a301d6682a3aab96e996e71b82d8e8c7a85e1d44524f2ed6fbdffc6bf236cdcadaa SHA512 c058d770a4ccfdf4e2e3a713748b6a705b6d3e148a903b9dbba4bba9d3ded2b819d7dfbfa37b9fad78e57c0a5f10f2f94226f8738f666e692a085ab297a36b36
diff --git a/sys-auth/rtkit/rtkit-0.13.ebuild b/sys-auth/rtkit/rtkit-0.13.ebuild
new file mode 100644
index 000000000000..c5a7b3105f06
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="https://0pointer.de/blog/projects/rtkit"
+SRC_URI="https://github.com/heftig/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="systemd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="acct-group/rtkit
+ acct-user/rtkit
+ sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~!RT_GROUP_SCHED"
+ ERROR_RT_GROUP_SCHED="CONFIG_RT_GROUP_SCHED is enabled. rtkit-daemon (or any other "
+ ERROR_RT_GROUP_SCHED+="real-time task) will not work unless run as root. Please consider "
+ ERROR_RT_GROUP_SCHED+="unsetting this option."
+ check_extra_config
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dinstalled_tests=false
+ $(meson_feature systemd libsystemd)
+ )
+ meson_src_configure
+}