summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-11 09:17:56 +0000
committerMarek Szuba <marecki@gentoo.org>2021-11-11 20:15:28 +0000
commit65aa7b43819af91c983da0b99718b49ef968366b (patch)
tree8ca5787a67cffd2cd0177c8c0d18722155419c65
parentsys-cluster/singularity: add 3.8.4 (diff)
downloadgentoo-65aa7b43819af91c983da0b99718b49ef968366b.tar.gz
gentoo-65aa7b43819af91c983da0b99718b49ef968366b.tar.bz2
gentoo-65aa7b43819af91c983da0b99718b49ef968366b.zip
x11-misc/xdotool: add 3.20211022.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--x11-misc/xdotool/Manifest1
-rw-r--r--x11-misc/xdotool/xdotool-3.20211022.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index 45d358a58802..31f3cdddb1e4 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1 +1,2 @@
DIST xdotool-3.20210903.1.tar.gz 115051 BLAKE2B d1be4fc2f5c86991804b63b85c95748dc04098f85a515b3427d980dac3d355133da0408d3e91a39e5363ae6242b02d268a8b5bc014fdd5faf51e43e24fb54176 SHA512 446ba8d354031df6a21957df92220c7dcaae5bacbb8878568a57f31097db72a88701717ec8bcd35cca3f5356bfaf47eb3ed65d2159f03b0c7a7ae5550a9b1dce
+DIST xdotool-3.20211022.1.tar.gz 115237 BLAKE2B 1269775848905253936b113ac45e2a5126f1414eeacb5dd91aea6dc0cb6993f9fa0da969f30c83e0e03d435894a31ba633dc02269b38f9056772b513f0c86889 SHA512 f11d7b079f19d1650adfb549ecc96e840805935bf4925beefc3238154ad0afbff36b134c78bfc73a9dc07fc869ab75676575d6de50cfd54484d2c35d6913ea27
diff --git a/x11-misc/xdotool/xdotool-3.20211022.1.ebuild b/x11-misc/xdotool/xdotool-3.20211022.1.ebuild
new file mode 100644
index 000000000000..849e4a9503b1
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-3.20211022.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
+HOMEPAGE="https://www.semicomplete.com/projects/xdotool/"
+SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# Many the tests want to manually start Xvfb regardless of whether there
+# is an X server running or not (i.e. does not play nicely with virtualx),
+# some tests require x11-wm/openbox, some try to run a complete Gnome
+# session. All of them require a Ruby interpreter with dev-ruby/minitest
+# installed. In short, supporting tests here will need MUCH work.
+RESTRICT="test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.20210804.2-no_hardcoded_pkg-config.patch
+ "${FILESDIR}"/${PN}-3.20210804.2-no_ldconfig.patch
+)
+
+DOCS=( CHANGELIST README.md )
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" INSTALLMAN="${ED}/usr/share/man" INSTALLLIB="${ED}/usr/$(get_libdir)" install
+
+ use examples && DOCS+=( examples )
+ einstalldocs
+}