summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-03 16:58:03 +0100
committerSam James <sam@gentoo.org>2022-01-04 03:28:46 +0000
commit65ad4c777d9cab090153c6e26ce5cd47a409eded (patch)
treefacff0fdb95aec72c6c69315eef188146e936574
parentnet-analyzer/synscan: remove kernel_FreeBSD (diff)
downloadgentoo-65ad4c77.tar.gz
gentoo-65ad4c77.tar.bz2
gentoo-65ad4c77.zip
net-fs/openafs: remove kernel_FreeBSD
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-fs/openafs/openafs-1.8.7.ebuild9
-rw-r--r--net-fs/openafs/openafs-1.8.8.1-r1.ebuild9
2 files changed, 2 insertions, 16 deletions
diff --git a/net-fs/openafs/openafs-1.8.7.ebuild b/net-fs/openafs/openafs-1.8.7.ebuild
index f2f6237fddcc..8d42811d43cf 100644
--- a/net-fs/openafs/openafs-1.8.7.ebuild
+++ b/net-fs/openafs/openafs-1.8.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -127,8 +127,6 @@ src_configure() {
fi
myconf+=( --with-linux-kernel-headers="${KV_DIR}" \
--with-linux-kernel-build="${KV_OUT_DIR}" )
- elif use kernel_FreeBSD; then
- myconf+=( --with-bsd-kernel-build="${BSD_BUILD_DIR}" )
fi
fi
@@ -187,9 +185,6 @@ src_install() {
MODULE_NAMES="libafs(fs/openafs:${srcdir})"
linux-mod_src_install
- elif use kernel_FreeBSD; then
- insinto /boot/modules
- doins "${S}"/src/libafs/MODLOAD/libafs.ko
fi
fi
@@ -286,7 +281,6 @@ pkg_preinst() {
pkg_postinst() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postinst
fi
@@ -309,7 +303,6 @@ pkg_postinst() {
pkg_postrm() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postrm
fi
}
diff --git a/net-fs/openafs/openafs-1.8.8.1-r1.ebuild b/net-fs/openafs/openafs-1.8.8.1-r1.ebuild
index 8fe9b5e98f6f..bedbe27e50a1 100644
--- a/net-fs/openafs/openafs-1.8.8.1-r1.ebuild
+++ b/net-fs/openafs/openafs-1.8.8.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -126,8 +126,6 @@ src_configure() {
fi
myconf+=( --with-linux-kernel-headers="${KV_DIR}" \
--with-linux-kernel-build="${KV_OUT_DIR}" )
- elif use kernel_FreeBSD; then
- myconf+=( --with-bsd-kernel-build="${BSD_BUILD_DIR}" )
fi
fi
@@ -186,9 +184,6 @@ src_install() {
MODULE_NAMES="libafs(fs/openafs:${srcdir})"
linux-mod_src_install
- elif use kernel_FreeBSD; then
- insinto /boot/modules
- doins "${S}"/src/libafs/MODLOAD/libafs.ko
fi
fi
@@ -285,7 +280,6 @@ pkg_preinst() {
pkg_postinst() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postinst
fi
@@ -308,7 +302,6 @@ pkg_postinst() {
pkg_postrm() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postrm
fi
}